Incoming Emails Are Delayed

Aug 19, 2018
5
0
1
India
cPanel Access Level
Root Administrator
Hello,

I am currently hosting a cPanel server myself . and I recently started facing issues with incoming emails

when I send an email from a Cpanel server it gets quickly to the party to whom I sent. but if an email sent from providers like
Google /Yahoo.etc

The email shows in inbox almost 5 min later. I really can't figure out where the issue lies. !!

but I did check Greylisting which is turned off. and I have ConfigServerFirewall installed.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Aug 19, 2018
5
0
1
India
cPanel Access Level
Root Administrator
Hello @varunsridharan,

I recommend sending an email from one of the remote mail servers you notice the issue with and then searching for it using cPanel >> Track Delivery. You can read more about this option on the document below:


Thank you.
Sorry about the delayed response. but its not showing any thing there.


i tried sending an email to my cPanel server from GoogleMail
 
Aug 19, 2018
5
0
1
India
cPanel Access Level
Root Administrator
Checked the exim log file for the corresponding email?
here is the log


Code:
2019-08-16 08:11:30 SMTP connection from [209.85.xxx.xx]:40201 (TCP/IP connection count = 1)
2019-08-16 08:12:08 SMTP connection from [127.0.0.1]:46026 (TCP/IP connection count = 2)
2019-08-16 08:12:08 SMTP connection from (localhost) [127.0.0.1]:46026 closed by QUIT
2019-08-16 08:12:11 1hySBu-00010N-Jz H=mail-lf1-f42.google.com [209.85.xxx.xx]:40201 Warning: "SpamAssassin as xxx detected message as NOT spam (0.1)"
2019-08-16 08:12:11 1hySBu-00010N-Jz <= [email protected] H=mail-lf1-f42.google.com [209.85.xxx.xx]:40201 P=esmtps X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no S=13876 [email protected]com T="Reg :O" for [email protected]
2019-08-16 08:12:11 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1hySBu-00010N-Jz
2019-08-16 08:12:11 SMTP connection from mail-lf1-f42.google.com [209.85.xxx.xx]:40201 closed by QUIT
2019-08-16 08:12:11 1hySBu-00010N-Jz => hello <[email protected]> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <[email protected]> 9oDHHwMYVl1WDwAA9wVvfg Saved"
2019-08-16 08:12:11 1hySBu-00010N-Jz Completed
the above log generated after a long time only when i send from gmail to my cpanel server the log is not getting generated quickly instead it takes a lot of time
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello @varunsridharan,

Can you browse to WHM >> Exim Configuration Manager >> ACL Options and temporarily disable the option below to see if the issue persists?

Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam

Thank you.
 
Aug 19, 2018
5
0
1
India
cPanel Access Level
Root Administrator
Hello @varunsridharan,

Can you browse to WHM >> Exim Configuration Manager >> ACL Options and temporarily disable the option below to see if the issue persists?

Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam

Thank you.

Hello @cPanelMichael

i did as you said. but there is no improvement over the transport time what so ever. :-(

and i am not sure if its something to do with my server setup. here is how my setup is done

1. 3rd Party DNS [ Not cPanel Builtin DNS System]
2. 2 servers [ 1. For Hosting Websites & 1. For Hosting Emails] -- Email server configured with SMTP Rely Service based on the documentation i found it in here
3. only the below services are enabled in my email server

1566004538988.png
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

Feel free to submit a ticket with us if you'd like us to take a closer look. You can post the ticket number here and we'll link this thread to it.

Thank you.