The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

incremental backups are counted against the clients quota

Discussion in 'General Discussion' started by akiyuki, Apr 12, 2007.

  1. akiyuki

    akiyuki Member

    Joined:
    Dec 2, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I got a problem for incremental backups.
    My customer complain to us that his disk usage shows double.
    I checked server, backup data was counted against the clients quota.
    I am using incremental backups,
    CPanel looks like counted the space used based on the account user, so all files owned by user count in the quota usage.
    anybody knows how to fix this issue?
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Put the backup directory on a separate partition. As long as it is on the same partition as /home all files will count against the users qutoa.
     
  3. yapluka

    yapluka Well-Known Member

    Joined:
    Dec 24, 2003
    Messages:
    301
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    France
    cPanel Access Level:
    Root Administrator
    I'm using the incremental backup as well and for some of my servers, the backups are stored in the /home/ partition, though /home/cpbackup/* is owned by root and the files don't count against user's quota.

    What you could do is create /scripts/postcpbackup if it doesn't exist, chmod it 700 and add there :

    Code:
    #!/bin/bash
    chown -R root.root /<<path to your>>/cpbackup/
    
    This should fix your issue :)
     
  4. akiyuki

    akiyuki Member

    Joined:
    Dec 2, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for solution.
    I will try to change permision.
    However my backup directory is not include home.
    Directroy name is /popwonder.
    I do not why it's happen.
     
  5. macooper

    macooper Member

    Joined:
    May 3, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    cpanel uses the quota system of the OS for keeping track of disk usage. If your backups are on their own partition, not shared with anything else, you need to turn off the quota for that partition. Login as root and run the command :

    quotaoff /backup

    replacing /backup with the name of your backups partition. This will only work if /backup is it's own partition, it is not possible to turn of quota's on a per directory basis.

    HTH
     
Loading...

Share This Page