The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Index Manager doesn't show any folders

Discussion in 'Security' started by TeZkO, Aug 20, 2008.

  1. TeZkO

    TeZkO Registered

    Joined:
    Aug 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I created a FTP account to upload a file on a daily basis to its asignated folder. I want that folder to be accesible by password only.

    I found out that i can do that on the Index Manager, but the problem is that the Index Manager doesn't show any folders! it only says the following:

    Code:
    The index manager will allow you to turn indexes on or off for a directory. If indexes are off, people will not be able to see what files are in a directory that lacks an index file.
    
    Please select the folder you wish to protect by clicking on its name. You can navigate by clicking on icons.
    
    
    
    [ Go Back ] 
    Does anyone know how to fix this?

    regards.
     
  2. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    What you want is to password protect the folder ? You can do it at user cpanel --> Password Protect Directories .
     
  3. TeZkO

    TeZkO Registered

    Joined:
    Aug 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello

    This are all the options I have on the main screen of my cPanel interface:
    What should I do to access "Password Protect Directories"?
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It seems your hosting provider has disabled this functionality for your account. You may want to contact them for assistance.
     
  5. MaestriaNick

    MaestriaNick Well-Known Member

    Joined:
    Aug 6, 2008
    Messages:
    159
    Likes Received:
    3
    Trophy Points:
    18
    may be it is not enabled for you. If you have no root access , request your host to enable it for your account.

    other way is to manually setup the protection using .htaccess.

    http://www.javascriptkit.com/howto/htaccess3.shtml , that may help for doing so.
     
  6. TeZkO

    TeZkO Registered

    Joined:
    Aug 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    hello again

    Actually I do have root access. how do I enable "Password Protect Directories"?
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It should be enabled by default. What theme are you using for the cPanel interface?
     
Loading...

Share This Page