The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

index pages not defaulting

Discussion in 'General Discussion' started by sendthisbotbck, Oct 17, 2004.

  1. sendthisbotbck

    sendthisbotbck Registered

    Joined:
    Oct 17, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    when I type in www.cst-6.net, it shows me everything in the directory although I have an index page in the folder.

    The same for the subdomain /wellness i have on the site.

    I thought it was a problem with the index manager, but I'm just not so sure. In my index manager I specified "Default System Setting," but that doesn't seem to take care of the problem.

    Also, with my /wellness subdomain, I'm getting a 500 error although I also specified I wanted "Default System Setting".

    Any ideas?
     
  2. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Paste your .htaccess file here for us to see :)

    /home/username/public_html/.htaccess
     
  3. sendthisbotbck

    sendthisbotbck Registered

    Joined:
    Oct 17, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I didn't even think of that. Here you go. I no longer have b2 on my domain. I'm operating with movable type. Here it is anyway:


    WWW.CST-6.NET:
    # Apache configuration for the blog folder

    # this will select the default blog template to be displayed
    # if the URL is just .../blogs/

    DirectoryIndex index.php



    # this will make register globals off in b2's directory
    # just put a '#' sign before these three lines if you don't want that

    php_flag register_globals off




    # this is used to make b2 produce links like http://example.com/archives/m/200209
    # if you renamed the file 'archives' to another name, please change it here too

    ForceType application/x-httpd-php

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^http://cst-6.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://cst-6.net$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://wellness.cst-6.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://wellness.cst-6.net$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.cst-6.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.cst-6.net$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.wellness.cst-6.net/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://www.wellness.cst-6.net$ [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]


    and WWW.CST-6.NET/wellness
    # Apache configuration for the blog folder

    # this will select the default blog template to be displayed
    # if the URL is just .../blogs/

    DirectoryIndex index.php



    # this will make register globals off in b2's directory
    # just put a '#' sign before these three lines if you don't want that

    php_flag register_globals off




    # this is used to make b2 produce links like http://example.com/archives/m/200209
    # if you renamed the file 'archives' to another name, please change it here too

    ForceType application/x-httpd-php
    Options All
    Options All
     
    #3 sendthisbotbck, Oct 18, 2004
    Last edited: Oct 18, 2004
  4. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    That's the problem.

    By default, index.xxx can be one of many extensions, but your .htaccess file says use index.php which doesn't exist. Either remove that line, or use an index.php file.
     
Loading...

Share This Page