The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Information schema query causing high diskio.

Discussion in 'Database Discussions' started by sahostking, Oct 8, 2014.

  1. sahostking

    sahostking Well-Known Member

    Joined:
    May 15, 2012
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cape Town, South Africa
    cPanel Access Level:
    Root Administrator
    Whenever these run I think it's affecting sites on the box and causing high diskio?

    Any idea what we can do? or to disable it?

    | 719 | root | localhost | information_schema | Query | 427 | checking permissions | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB' |
    | 1912 | root | localhost | information_schema | Query | 132 | checking permissions | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'
     
  2. sahostking

    sahostking Well-Known Member

    Joined:
    May 15, 2012
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cape Town, South Africa
    cPanel Access Level:
    Root Administrator
    Seeing more of it now.

    Code:
    |  8104 | root             | localhost | information_schema | Query          | 4355 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    |  9257 | root             | localhost | information_schema | Query          | 4054 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 10533 | root             | localhost | information_schema | Query          | 3754 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 11800 | root             | localhost | information_schema | Query          | 3456 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 12936 | root             | localhost | information_schema | Query          | 3155 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 14069 | root             | localhost | information_schema | Query          | 2855 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 15068 | root             | localhost | information_schema | Query          | 2554 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 16131 | root             | localhost | information_schema | Query          | 2255 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 17130 | root             | localhost | information_schema | Query          | 1953 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 18125 | root             | localhost | information_schema | Query          | 1654 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
    | 19030 | root             | localhost | information_schema | Query          | 1356 | checking permissions         | SELECT count(*) FROM tables WHERE ENGINE = 'InnoDB'                                                  |
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,767
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    This is likely stems from the following option that's configured in "Tweak Settings":

    Use INFORMATION_SCHEMA to acquire MySQL® disk usage

    Per it's description:

    Using INFORMATION_SCHEMA ensures that disk usage by MySQL tables is included in totals. However, enabling this option may cause a significant drop in performance as MySQL may become unresponsive until data collection is complete. Disabling this option causes the system to query the filesystem directly, potentially excluding disk space used by some database tables. Note: If you use a remote MySQL server, you must turn this setting On in order to calculate MySQL disk usage.

    You may want to disable this option to see if it helps improve performance.

    Thank you.
     
  4. sahostking

    sahostking Well-Known Member

    Joined:
    May 15, 2012
    Messages:
    300
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cape Town, South Africa
    cPanel Access Level:
    Root Administrator
    It is disabled already - saw that a few months ago and tried it. Never made a difference.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,767
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may want to run a MySQL tuner to help determine which modifications to make to your /etc/my.cnf to help improve MySQL performance.

    Thank you.
     

Share This Page