oozetime

Member
Aug 22, 2014
22
0
1
cPanel Access Level
Root Administrator
Hello,

I disabled the ini_set as requested firewall csf. Since it is unsafe to use it, as a client or intruder can disable functions that give permission to break into websites and dbs.

But with the ini_set unable, some of my clients have problems with joomla and wordpress.

Follows the message of some of the errors:

Warning: ini_set() has been disabled for security reasons in /home/apoioser/public_html/novo/libraries/joomla/session/session.php on line 100

Warning: ini_set() has been disabled for security reasons in /home/apoioser/public_html/novo/libraries/joomla/session/session.php on line 103

Warning: ini_set() has been disabled for security reasons in /home/apoioser/public_html/novo/libraries/joomla/session/session.php on line 831

Font: - removed -
How to get around this?
 
Last edited by a moderator:

server9host

Well-Known Member
Sep 18, 2013
160
0
16
India
cPanel Access Level
Root Administrator
Hello,

You need to enable ini_set() on server or create custom php.ini for your single user.
 

mageshm

Well-Known Member
Apr 17, 2014
90
1
6
Chennai, INDIA
cPanel Access Level
DataCenter Provider
Hi,

For security reason most of the shared hoster disabled below function globally.

disable_functions = "phpinfo,exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file,show_source,allow_url_fopen,allow_url_include,ini_set"

Just create php.ini file corresponding user public_html folder and add the below line to enable ini_set.

ini_set = on

If you have root access do the below and remov the ini_set from "disabled_function"

cp /usr/local/lib/php.ini /home/username/public_html/