The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Initial Quota Setup Error Please Help

Discussion in 'General Discussion' started by pleasehelpcpane, Jun 30, 2013.

  1. pleasehelpcpane

    pleasehelpcpane Registered

    Joined:
    Jun 22, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ever since i updated cpanel Quotas was all messed up so i read around and found that i should run Initial Quota Setup but when i do i get this error
    Code:
    
    Installing Default Quota Databases......Done
    Quota Mode: Linux
    journaled quota support: kernel supports, user space tools supports (available)
    checking out /backup
    / (already configured quotas = 1).
    /tmp (already configured quotas = 0).
    /boot (already configured quotas = 0).
    Updating Quota Files......
    	quotacheck: Scanning /dev/root [/] |/-\|
    -\quotacheck: Cannot stat old user quota file: No such file or directory
    	quotacheck: Old group file not found. Usage will not be substracted.
    	quotacheck: Checked 39237 directories and 333688 files
    	quotacheck: Can't create new quotafile //quota.user.new: File exists
    	quotacheck: Cannot initialize IO on new quotafile: File exists
    	done
    	
    ....Done
    Quotas have been enabled and updated.
    edquota: Quota file not found or has wrong format.
    No filesystems with quota detected.
    Resetting quota for username to 0 M
    
    This is my cat /etc/fstab
    Code:
    cat /etc/fstab
    LABEL=/	/	ext3	usrjquota=quota.user,jqfmt=vfsv0	1	1
    LABEL=/tmp              /tmp                    ext3    noexec,nosuid,nodev        1 2
    LABEL=/boot             /boot                   ext2    defaults        1 2
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    LABEL=SWAP-sda3         swap                    swap    defaults        0 0
    /tmp             /var/tmp                    ext3    defaults,bind,noauto        0 0
    
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please try running the following command and let us know know the output:

    Code:
    quotacheck -vguma
    Also, is this a VPS? If so, have you tried disabling/enabling quotas for this VPS from the VPS hardware node?

    Thank you.
     
  3. pleasehelpcpane

    pleasehelpcpane Registered

    Joined:
    Jun 22, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    When i run the above coommand i get
    Code:
    quotacheck -vguma
    quotacheck: Unknown quota format: vfsv0,
    Supported formats are:
      vfsold - original quota format
      vfsv0 - new quota format
      rpc - use RPC calls
      xfs - XFS quota format
    quotacheck: Cannot detect quota format for journalled quota on /
    quotacheck: Cannot guess format from filename on /dev/root. Please specify format on commandline.
    quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
    
    no this is not a vps this is a dedicated server
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The primary error message I notice is:

    Code:
    No filesystems with quota detected.
    Have you tried switching from journaled quota to standard quota? For instance, you would edit this line in your /etc/fstab file:

    Code:
    LABEL=/	/	ext3	usrjquota=quota.user,jqfmt=vfsv0	1	1
    To:

    Code:
    LABEL=/	/	ext3	defaults,usrquota 1 1
    After that, you would remount the "/" partition.

    Thank you.
     
Loading...

Share This Page