The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

innoDB tables corrupt, mySQL failing to restart

Discussion in 'General Discussion' started by TheBiggestGnome, Jun 3, 2011.

  1. TheBiggestGnome

    TheBiggestGnome Registered

    Mar 13, 2007
    Likes Received:
    Trophy Points:
    Good Afternoon,

    I have tried to contact support to fix the issue I am having, but they have suggested to get a DBA to fix the issues I'm having. While, in a perfect world I would be more than willing to do this, I don't have access to the cash in order to do it. While DB's are something familiar to myself and I'm pretty good at managing them, I'm at a loss as to where to start. The information below is what I can gather, as well as what cPanel support has helped me with.

    I have tried to follow the below post, but sadly, mySQL will not restart.
    Failed to locate MySQL socket. Please check the mysql configuration.
    110602 00:47:16  mysqld started
    110602  0:47:16  InnoDB: Started; log sequence number 0 2841369259
    110602  0:47:16 [Note] /usr/local/libexec/mysqld: ready for connections.
    Version: '5.0.92'  socket: '/tmp/mysql.sock'  port: 3306  FreeBSD port: mysql-server-5.0.92
    110602 16:00:00  mysqld restarted
    InnoDB: The log sequence number in ibdata files does not match
    InnoDB: the log sequence number in the ib_logfiles!
    110602 16:00:00  InnoDB: Database was not shut down normally!
    InnoDB: Starting crash recovery.
    InnoDB: Reading tablespace information from the .ibd files...
    110602 16:00:00  InnoDB: Operating system error number 2 in a file operation.
    InnoDB: The error means the system cannot find the path specified.
    InnoDB: If you are installing InnoDB, remember that you must create
    InnoDB: directories yourself, InnoDB does not create them.
    InnoDB: File name ./mysql.sock
    InnoDB: File operation call: 'stat'.
    InnoDB: Error: os_file_readdir_next_file() returned -1 in
    InnoDB: directory .
    InnoDB: Crash recovery may have failed for some .ibd files!
    InnoDB: Restoring possible half-written data pages from the doublewrite
    InnoDB: buffer...
    110602 16:00:00  InnoDB: Started; log sequence number 0 2880656864
    110602 16:00:00 [Note] /usr/local/libexec/mysqld: ready for connections.
    Version: '5.0.92'  socket: '/tmp/mysql.sock'  port: 3306  FreeBSD port: mysql-server-5.0.92
    110602 21:40:17 [Note] /usr/local/libexec/mysqld: Normal shutdown
    110602 21:40:19  InnoDB: Starting shutdown...
    110602 21:40:22  InnoDB: Shutdown completed; log sequence number 0 2895265601
    110602 21:40:22 [Note] /usr/local/libexec/mysqld: Shutdown complete
    110602 21:40:22  mysqld ended
    This issue was caused suddenly and without any kind of warning as far as I can tell. There wasn't any recent additions from what I can tell. I'm completely at a loss as to why this happened... What could possibly be the fix for this?
  2. smoge

    smoge Well-Known Member

    Jul 2, 2004
    Likes Received:
    Trophy Points:
    You run out of disc space?

Share This Page