The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782.

Discussion in 'General Discussion' started by jsteel, Mar 15, 2004.

  1. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Since upgrading to 9.1.0-R83, users are getting the following access their stats:

    Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782.

    Anyone else encounter it and have a quick fix before we open a ticket and possibly wait a day or two for a response?
     
  2. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    What version of Perl do you have? (Perl -v)
     
  3. maxime

    maxime Member

    Joined:
    Aug 13, 2001
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have the same issue on all my boxes.

    If anyone has got a suggestion, I'm interested !

    Thanks.

    Maxime
     
  4. maxime

    maxime Member

    Joined:
    Aug 13, 2001
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Re: Re: Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 7

    I have v5.6.1

    Regards,

    Maxime
     
  5. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    mmm...Okay, should be fine with 5.6.1, as I think it didn't support it before 5.6.0.

    You might try /scripts/perlinstaller though. Just to upgrade, can't hurt.
     
  6. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    5.6.1 (from cPanel's installer)
     
  7. MichaelShanks

    MichaelShanks Well-Known Member
    PartnerNOC

    Joined:
    Aug 20, 2001
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    its happening in on a lot of boxes for us currently, looks like a new "undocumented feature"
     
  8. JC

    JC Well-Known Member

    Joined:
    Nov 6, 2002
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Yep I'm getting this too.
    Did the fix above solve it for anyone?
     
  9. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Since others have the issue, I've opened a ticket.
     
  10. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    I wouldn't recommend that as a 'fix' at the current time.
     
  11. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Well, basically, the version of File::Find packaged with versions of perl before 5.6.0 do not support chdir (or no_chdir) in Tainted mode especially.

    However, being everyone is running 5.6.1 apparently...who knows :)
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Well, I'm running 5.8.1 and have this problem too with 9.1.0-RELEASE 83 :(
     
  13. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Weird...there goes that theory. Unless of course cPanel uses it's own version of perl too? I'm starting to think maybe Nick just forgot to remove the -T flag. I'm sure it'll get fixed soon enough :)
     
  14. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here.

    Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782, <NS> line 32.
    Running edge 81
     
  15. Allin1Joe

    Allin1Joe Member

    Joined:
    Feb 28, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Yep, same here.
     
  16. LP-Trel

    LP-Trel Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Nirvana
    Same here, come on Nick fix it! :D
     
  17. xstaci2k2

    xstaci2k2 Member

    Joined:
    Nov 23, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    same problem here. on both of my servers. yes, plz a fix needs to be made.
     
  18. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Ticket Update

    Posting Ticket ID for future reference.

    cPanel.net Support Ticket Number: 43145
     
  19. ladymacbeth

    ladymacbeth Member

    Joined:
    Nov 17, 2002
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Hi,

    I made the cpanel version in the server to the latest stable one and the issue was fixed for me... :D

    Regards
    Reeshma
     
  20. jsteel

    jsteel Well-Known Member

    Joined:
    Jul 4, 2002
    Messages:
    646
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Atlanta, GA
    Please post the version you are showing in your WHM interface.
     
Loading...

Share This Page