Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782.

jsteel

Well-Known Member
Jul 4, 2002
646
0
166
Atlanta, GA
Since upgrading to 9.1.0-R83, users are getting the following access their stats:

Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782.

Anyone else encounter it and have a quick fix before we open a ticket and possibly wait a day or two for a response?
 

nickn

Well-Known Member
PartnerNOC
Jun 15, 2003
619
1
168
Originally posted by jsteel
Since upgrading to 9.1.0-R83, users are getting the following access their stats:

Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782.

Anyone else encounter it and have a quick fix before we open a ticket and possibly wait a day or two for a response?
What version of Perl do you have? (Perl -v)
 

maxime

Member
Aug 13, 2001
16
0
301
Hi,

I have the same issue on all my boxes.

If anyone has got a suggestion, I'm interested !

Thanks.

Maxime
 

maxime

Member
Aug 13, 2001
16
0
301
Re: Re: Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 7

Originally posted by snickn
What version of Perl do you have? (Perl -v)
I have v5.6.1

Regards,

Maxime
 

nickn

Well-Known Member
PartnerNOC
Jun 15, 2003
619
1
168
mmm...Okay, should be fine with 5.6.1, as I think it didn't support it before 5.6.0.

You might try /scripts/perlinstaller though. Just to upgrade, can't hurt.
 

nickn

Well-Known Member
PartnerNOC
Jun 15, 2003
619
1
168
Well, basically, the version of File::Find packaged with versions of perl before 5.6.0 do not support chdir (or no_chdir) in Tainted mode especially.

However, being everyone is running 5.6.1 apparently...who knows :)
 

nickn

Well-Known Member
PartnerNOC
Jun 15, 2003
619
1
168
Originally posted by chirpy
Well, I'm running 5.8.1 and have this problem too with 9.1.0-RELEASE 83 :(
Weird...there goes that theory. Unless of course cPanel uses it's own version of perl too? I'm starting to think maybe Nick just forgot to remove the -T flag. I'm sure it'll get fixed soon enough :)
 

jackal

Well-Known Member
PartnerNOC
Feb 23, 2002
708
0
316
Same problem here.

Insecure dependency in chdir while running with -T switch at cpsrvd.pl line 782, <NS> line 32.
Running edge 81
 

jsteel

Well-Known Member
Jul 4, 2002
646
0
166
Atlanta, GA
Originally posted by ladymacbeth
Hi,

I made the cpanel version in the server to the latest stable one and the issue was fixed for me... :D

Regards
Reeshma
Please post the version you are showing in your WHM interface.