Install a not listed version of Php/apache

Sandman21dan

Registered
Apr 2, 2014
3
0
1
cPanel Access Level
Root Administrator
Hello!

I'm new to this community although not exactly new to using cPanel.

I have several servers and lots of code based on a specific version of Php, however on my development server I have, has a newer version of Php and I wish to install an older one that it's not listed on Whm Easy-apache list.


To be more specific, I'm on version 11.42.0.4 of Whm

On easy-apache installer I get these apache versions


Apache 2.2.27 [ Hide Info ]
Newest version from the Apache project with performance improvements over Apache 2.

Apache 2.4.9 [ Hide Info ]
Newest version from the Apache project with performance improvements over Apache 2.2.


And these Php Versions

None
5.3.27 END OF LIFE
5.3.28 DEPRECATED
5.4.26
5.5.10 EXPERIMENTAL


Now... I need Php version 5.3.17

But obviously it's not listed.

Currently I don't have the Ssh root password for my dedicated server, however this is being sorted out.


If you know anyway of installing a non listed version of Php please let me know.

Grateful for any help.


PD: Before you say that I should upgrade my code (and I know I do, and I will), I really need to get some stuff running pretty soon and that's the reason a need to downgrade to Php 5.3.17d

Thanks!
 

ThinIce

Well-Known Member
Apr 27, 2006
352
9
168
Disillusioned in England
cPanel Access Level
Root Administrator
You might want to look at php selector from cloudlinux

Getting latest PHP in cPanel with PHP Selector

To say more - while using PHP Selector, you do not need to use EasyApache anymore for any php modules or extensions, as it all being automatically handled by RPMs. Necessary PHP version is selected per user. One user may use 5.5.0 for his scripts and the other might choose version 4.4.9.
 

Sandman21dan

Registered
Apr 2, 2014
3
0
1
cPanel Access Level
Root Administrator
You might want to look at php selector from cloudlinux

Getting latest PHP in cPanel with PHP Selector
That's very interesting although it seems to be for your cPanel user or accounts to be able to change between many already installed versions of PHP, in my case i've only one main version installed by WHM.



Out of curiosity, what works in PHP version 5.3.17 that does not work in 5.3.28?

PHP version 5.2.17 is a more common request. If that is what you meant, check out this post: http://forums.cpanel.net/f442/question-about-easyapache-php-5-2-a-400521.html#post1610381
It's definitely 5.3.17 not 5.2, what runs on it is OSCommerce 2.2 and lots and lots of addons, modules, plugins, etc...
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
It's definitely 5.3.17 not 5.2, what runs on it is OSCommerce 2.2 and lots and lots of addons, modules, plugins, etc...
You should be able to use PHP 5.3.28 for an application that specifically requires PHP 5.3.17. Notice both versions are PHP 5.3, with the newer one including security patches/bug fixes.

Thank you.
 

Sandman21dan

Registered
Apr 2, 2014
3
0
1
cPanel Access Level
Root Administrator
You should be able to use PHP 5.3.28 for an application that specifically requires PHP 5.3.17. Notice both versions are PHP 5.3, with the newer one including security patches/bug fixes.

Thank you.
I agree, they should, but for some reason lots of stuff breaks.

And that means thousand of thousand of little fixes everywhere.

For example:

Shopping Cart breaks, SEO Friendly links breaks, some parts of the active accounts detection breaks, and eBay API breaks...

All from 5.3.17 to 5.3.27

Which I agree it's completely absurd, but it's happening... And as is said before, I know I should update this code but I need to put some of this work live sooner rather than later...

So is there really no way to install that specific version of php?

What if I had the root ssh password for the dedicated server?

Thanks!
 

Shavaun

Well-Known Member
Aug 15, 2013
106
0
91
cPanel Access Level
Root Administrator
Within EasyApache itself, there is no way to do that. We update the minor versions for security reasons and recommend that our users do the same. It might also be worth noting that PHP version 5.3 will no longer receive security updates as of July this year.

You might have already done these, but the only other suggestions I can think of are:
- Check the support for the various plugins/scripts that are not working, to see if maybe there is a setting or some other mechanism that would allow you to make it cooperate. What you are describing is odd enough that surely someone else must have run into it as well. If it is a bug in the OSCommerce software for example, they might have a solution on their forums.
- Check to see if PHP 5.2 would work with it. You might find this document helpful to see if that is the case: PHP: Migrating from PHP 5.2.x to PHP 5.3.x - Manual You would need root (or root privileges) SSH access to the server to add the PHP 5.2 opt mod.

Sorry I can't be more help, I hope you are able to resolve the issue in a reasonable time period.
 
Last edited:

d-woo

Well-Known Member
Aug 9, 2003
88
0
156
I am in the same position as Sandman21dan.

I recently had an OS reload, due to a hardware issue.

The only site that I run on this server is a shop using OSCommerce.

Although I understand the security risks involved with PHP 5.3.17 versus PHP 5.4.x (which was installed on the reload), the problem with OSCommerce is this. There are newer versions of OSCommerce which now work with PHP 5.4.x, however if your store was created with an earlier version of OS Commerce and you have added modules (and I have over 10 modules) then some, if not most, of those modules will no longer function when you upgrade your version of OSCommerce.

The only solution then is to either:

a. go back to PHP 5.3.17 (temporarily) so that your store can run properly and in the meantime you can develop on another site, your modules so that they work with PHP5.4.x and the new versions of OSCommerce

or

b. go through thousands of lines of code in your existing heavily modified OSCommerce version, making changes to deprecated functions and such.

I have attempted "b". I am on day 3 and still going.

How can I go to "a" an earlier version of PHP, specifically PHP5.3.17?

I have no other sites on this server, so I'm not concerned about anything breaking. Yes I have root access to the server.

Thanks!
 

d-woo

Well-Known Member
Aug 9, 2003
88
0
156
I got my OSCommerce back to running by using EasyApache in WHM and recompiling PHP back to 5.3.27

There is not much difference between PHP 5.3.27 and PHP 5.3.17

The problems really come in with PHP 5.4.x as there are quite a few deprecated functions.

I know that PHP5.3.27 is EOL, so I really need to get on the ball with my OS Commerce version on a dev server.