Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Install & Configure Subversion - Easyapache 3 - Apache 2.4 - Subversion 1.9.8 - Php 5.6

Discussion in 'General Discussion' started by cic&whitebox, Apr 6, 2016.

  1. cic&whitebox

    cic&whitebox Registered

    Joined:
    Apr 6, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Argentina
    cPanel Access Level:
    Root Administrator
    Hi all

    I'm currently want to install Subversion 1.9 on this system:
    Easyapache 3
    Apache 2.4
    Php 5.6
    CENTOS 7.2 x86_64
    WHM 54



    I've search in a lot of forums, try to compile subversion, install from yum, almost everything, but with no luck.

    My system config now is:

    httpd -M | grep svn
    dav_svn_module (shared)
    authz_svn_module (shared)

    svn --version
    svn, version 1.9.3 (r1718519)
    compiled Apr 4 2016, 23:57:14 on x86_64-unknown-linux-gnu



    On apache config I've added the load the libraries:

    LoadModule dav_svn_module /usr/local/libexec/mod_dav_svn.so
    LoadModule authz_svn_module /usr/local/libexec/mod_authz_svn.so


    but when I try to add the location in apache config

    <Location /svn>
    DAV svn
    SVNParentPath /home/svn
    Require valid-user
    AuthName "Subversion repository"
    AuthUserFile /etc/svn-auth-users
    </Location>


    I get this error:

    Configuration problem detected on line 2 of file /usr/local/apache/conf/includes/pre_virtualhost_2.conf.tmp: Unknown DAV provider: svn --- /usr/local/apache/conf/includes/pre_virtualhost_2.conf.tmp --- 1 2 ===> DAV svn <=== 3SVNParentPath /home/whitebox/repos 4AuthType Basic 5AuthName “Whitebox - SVN Server” 6AuthUserFile /etc/svn-auth.htpasswd 7Require valid-user 8 --- /usr/local/apache/conf/includes/pre_virtualhost_2.conf.tmp --


    Could anyone give me some help

    Regards,
     
  2. JacobPerkins

    JacobPerkins Well-Known Member

    Joined:
    May 2, 2014
    Messages:
    619
    Likes Received:
    97
    Trophy Points:
    103
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Hi,

    Are you loading your DAV SVN configurations in the pre_virtual_host include? Check to make sure that you're loading the modules (LoadModule) before the include line.
     
  3. Nacho Albano

    Nacho Albano Registered

    Joined:
    Mar 28, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Mar del Plata
    cPanel Access Level:
    Root Administrator
    Hi, I have a similar system configuration and I need to install subversion in my Centos 7, but when executing yum install subversion mod_dav_svn system tell me that I need a httpd version above than 2.2.3 and I have installed Apache 2.4.25... I did a migration to a new VPS and I cannot re install subversion. Any help?
    Thanks!
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,521
    Likes Received:
    1,964
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice