The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

install of curl-7.9.5-2.2.legacy conflicts with file from package curl-ssl-7.10.3-1

Discussion in 'General Discussion' started by jackie46, Aug 22, 2005.

  1. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    I am running the latest stable S83 and everytime /scripts/upcp runs we get the follow error.

    ('file /usr/share/man/man1/curl.1.gz from install of curl-7.9.5-2.2.legacy conflicts with file from package curl-ssl-7.10.3-1', (7, '/usr/share/man/man1/curl.1.gz', 0L))
    Testing connection speed...(this could take a while)....Done
    Three usable mirrors located

    We already ran easyapache and running upcp after running easyapache still show the abve error.
     
  2. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0
    Does anyone know?
     
  3. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    You can do rpm -e --nodeps curl-7.9.5-2.2.legacy and then run yum install curl (assuming you're using yum) or /scripts/upcp. What distro/version are you using? Why are you using a legacy RPM while you're running a repo with new RPMs?
     
  4. jackie46

    jackie46 BANNED

    Joined:
    Jul 25, 2005
    Messages:
    537
    Likes Received:
    0
    Trophy Points:
    0

    We are running RH 7.3. UPCP tries to install Legacy which is wrong. Why does it try to install Legacy on RH 7.3? This is a cpanel update issue not my blunder.

    rpm -e --nodeps curl-7.9.5-2.2.legacy
    error: package curl-7.9.5-2.2.legacy is not installed
    root@srv07 [/home/admin]#
     
    #4 jackie46, Sep 9, 2005
    Last edited: Sep 9, 2005
  5. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    It's trying to install the Legacy RPMs for RH7.3 beacuse that's what your yum's configuraed for (as it probobly should be). Do you need a specific version of Curl? If not, you should just use the Legacy RPMs for RH7.3 as those are backported with security and other important updates from new versions, and still compatable/stable with RH7.3.

    If you want to remove the package it's conficting with, do rpm -e --nodeps curl-ssl-7.10.3-1 and then try again (I got it backwards with the last post...my bad :rolleyes: ).
     
Loading...

Share This Page