The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install PDO_MYSQL

Discussion in 'General Discussion' started by Aldweb, Jan 22, 2007.

  1. Aldweb

    Aldweb Well-Known Member

    Joined:
    Feb 18, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    I installed PDO_MYSQL in my server, and in the end of the installation, appeared the following message:

    Build process completed successfully
    Installing ' /var/tmp/pear-build-root/install-PDO_MYSQL-1.0.2//usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so '
    install ok: channel://pecl.php.net/PDO_MYSQL-1.0.2
    You should add " extension=pdo.so " to php.ini
    You should add " extension=pdo_mysql.so " to php.ini

    I added in the php.ini "extension=pdo.so" and "extension=pdo_mysql.so". But when I access in my site phpinfo.php, it doesn't list that the pdo_mysql is installed, just list:

    PDO
    PDO SUPPORT ENABLED
    PDO DRIVERS SQLITE2

    Somebody would know how to do so that appears in the php.ini? because for the that I saw, it is installed.

    Thanks
     
  2. Aldweb

    Aldweb Well-Known Member

    Joined:
    Feb 18, 2004
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    6
    Its work now:

    updatedb
    locate pdo.so
    locate pdo_mysql.so

    root@server1 [/]# locate pdo.so
    /usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo.so

    root@server1 [/]# locate pdo_mysql.so
    /usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so

    Im adding this to php.ini

    extension=/usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo.so
    extension=/usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so

    /etc/init.d/httpd restart
     
Loading...

Share This Page