Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Install php 7.2 interbase?

Discussion in 'EasyApache' started by Kewi, Jun 13, 2019.

  1. Kewi

    Kewi Registered

    Joined:
    Jun 13, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kayseri
    cPanel Access Level:
    Root Administrator
    hello sorry for my bad english but it is important for me . I can not find any document for this problem.
    i had php 7.2 in apache but can not install pdo interbase
    so i uncheck php 7.2 from easyapache profile for reinstall but now i can not see php7.2 in apache profile. i tried to insatall php 7.2 on ssh that:
    yum install ea-php72

    it said:
    ea-php72 does not have a package available.
    Error: Nothing to do

    how can i install php 7.2 again and pdo interbase for firebird
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,456
    Likes Received:
    503
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hello @Kewi

    Can you run the following:

    Code:
    rpm -qa |grep ea-php72
    And provide the output?

    Also, we do not offer pdo_firebird but we do offer PDO for php 7.2

    Code:
    ea-php72-php-pdo.x86_64 : A database access abstraction module for PHP applications
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Kewi

    Kewi Registered

    Joined:
    Jun 13, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kayseri
    cPanel Access Level:
    Root Administrator


    rpm -qa |grep ea-php72
    output:

    [[email protected] laravel]# rpm -qa |grep ea-php72
    ea-php72-php-mysqlnd-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-imap-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-ioncube10-10.3.2-2.2.15.cpanel.x86_64
    ea-php72-pear-1.10.7-1.1.18.cpanel.noarch
    ea-php72-php-calendar-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-7.2.19-1.1.1.cpanel.x86_64
    ea-php72-php-devel-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-bcmath-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-zip-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-common-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-gd-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-ftp-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-sockets-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-cli-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-curl-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-posix-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-mbstring-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-iconv-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-pdo-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-php-xml-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-libc-client-2007f-14.14.2.cpanel.x86_64
    ea-php72-php-fpm-7.2.19-1.1.3.cpanel.x86_64
    ea-php72-runtime-7.2.19-1.1.1.cpanel.x86_64
    ea-php72-php-litespeed-7.2.19-1.1.3.cpanel.x86_64
     
  4. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,456
    Likes Received:
    503
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    This show's you have PHP 7.2 installed as well as PDO for PHP 7.2
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Kewi

    Kewi Registered

    Joined:
    Jun 13, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kayseri
    cPanel Access Level:
    Root Administrator
    yes but i wannt to use interbase extension on php 7.2. when i try to connect with pdo firebird an error occured that "driver can not found"
     
  6. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,456
    Likes Received:
    503
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Kewi

    Kewi Registered

    Joined:
    Jun 13, 2019
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kayseri
    cPanel Access Level:
    Root Administrator
    thanks for your reply.
    İ wanna to install this
    Code:
    https://centos.pkgs.org/7/ius-x86_64/php72u-interbase-7.2.17-1.ius.centos7.x86_64.rpm.html']php72u-interbase-7.2.17-1.ius.centos7.x86_64.rpm CentOS 7 Download
    like that command

    Code:
     rpm -Uvh https://dl.iuscommunity.org/pub/ius/stable/CentOS/7/x86_64//php72u-interbase-7.2.17-1.ius.centos7.x86_64.rpm

    but it gives an error
    Failed dependencies:
    php-pdo(x86-64) = 7.2.17-1.ius.centos7 is needed by php72u-interbase-7.2.17-1.ius.centos7.x86_64


    i look for php-pdo was intalled that ea-php71-php-pdo.x86_64 how can i fix this error ?
     
    #7 Kewi, Jun 21, 2019
    Last edited by a moderator: Jun 21, 2019
  8. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,456
    Likes Received:
    503
    Trophy Points:
    263
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    The problem with this is it's looking for/requiring the php-pdo package from ius not the php-pdo package you have installed from the EA4 repository.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice