Pauldomain

Registered
Jun 29, 2016
3
0
1
New Zealand
cPanel Access Level
Root Administrator
Hi there,

I am about to install the PHP 7.1 and PHP 7.2 package on my server but I have read that it may break my server and that I should perform certain checks as to the compatibility.

The packages are available for me to install in WHM.

Can someone please provide me with some guidelines as to what I need to test/check to ensure that installing the PHP 7.1 and PHP 7.2 packages will be fine.
 

Attachments

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston
Hi @Pauldomain

There is absolutely no reason why installing alternate php versions on your server would cause an issue. The only issue you could potentially come across is if you assign one of those php versions to your site and it's incompatible. If your sites are built on CMS software like WordPress which is up to date you should have no issues at all. It really depends on the site, my only word of advice would be to install the same modules for php 7.2 and 7.1 that you have installed for the other versions of php.


Thanks!