Install PHP development package - CentOS 6 PHP 7.3

monkey64

Well-Known Member
Nov 6, 2011
103
4
68
cPanel Access Level
Root Administrator
Hi

I am trying to install the MaxMind DB Reader PHP API C extension. The notes mention that "You may need to install the PHP development package on your OS such as php5-dev for Debian-based systems or php-devel for RedHat/Fedora-based ones." I've tried the install without php-devel but it doesn't work. So I'm looking to install php-devel.

I tried:

Code:
yum install php-devel
which returned : No package php-devel available.

Presumably it needs to be installed for the exact PHP version. I'm on CentOS 6, running PHP-FPM with PHP 7.3.

So then I Googled the above and it took me here
It looks promising but I have no experience installing rpm's and I'm starting to get a bit out of my depth. There are loads of repos out there - the name "remi" comes up often.

Can anyone help and tell me where I need to go and what I need to do to install?

Thanks
 
Last edited by a moderator: