Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install php71-php-intl with a more recent version of ICU

Discussion in 'EasyApache' started by ensensis, Jan 27, 2018.

  1. ensensis

    ensensis Registered

    Joined:
    Jan 27, 2018
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Costa RIca
    cPanel Access Level:
    Root Administrator
    Hello, everyone.
    I need to install php71-php-intl as required by my client. I know that it could be installed via EasyApache 4, however my system is running a ICU version too old (4.2). I need to install this extension compiled with a ICU version most recent as possible.
    Please, let me know how can I upgrade ICU version let say 57v in order to install php71-php-intl.

    PS: Searching in this forum I found a very similar topic: Internationalization extension version upgrade
    The users states thar ICU is found in EasyApache 4, but I do not see it there.

     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,734
    Likes Received:
    1,706
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You should should the following as part of the output when running a command such as "/opt/cpanel/ea-php71/root/usr/bin/php -i|grep icu":

    Thus, you could replace the existing ICU RPM with a custom one if you prefer, but keep in mind that is unsupported. I recommend reaching out to the developer of the script that's getting installed to verify if this is a requirement and if it's worth the effort to manually install a new RPM.

    Thank you.
     
Loading...

Share This Page