Install problem for FreeBSD

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
I have a new client just did a custom (minimal) install of FreeBSD RELEASE 4.10. Then after cvsup for its ports tree and doing portupgrade, kernel compilation I go ahead to install WHM/cPanel. I think some bugs in the installer:
Code:
cd /home ; mkdir cpins ; cd cpins; fetch http://layer1.cpanel.net/latest
sh latest
Here is the message shown:
Code:
localhost# sh latest
Creating directory installd
Verifying archive integrity... All good.
Uncompressing cplyr1-cPanel.........................................................................................................................................................................
      ____                  _
  ___|  _ \ __ _ _ __   ___| |
 / __| |_) / _` | '_ \ / _ \ |
| (__|  __/ (_| | | | |  __/ |
 \___|_|   \__,_|_| |_|\___|_|

FreeBSD detected!

***************** cPanel for FreeBSD ******************

Welcome to the cPanel installer for FreeBSD.

*******************************************************

scripts/HTTPreq.pm -> /scripts/HTTPreq.pm
scripts/portsup -> /scripts/portsup
scripts/pkgmap.pl -> /scripts/pkgmap.pl
scripts/installport.pl -> /scripts/installport.pl
scripts/fileversion.pl -> /scripts/fileversion.pl
scripts/ensurepkg2 -> /scripts/ensurepkg2
scripts/ensurepkg -> /scripts/ensurepkg
scripts/cpsources.pl -> /scripts/cpsources.pl
scripts/cPanelRPM.pm -> /scripts/cPanelRPM.pm
scripts/cPanelBSDPKGS.pm -> /scripts/cPanelBSDPKGS.pm
scripts/bsdpkgpingtest -> /scripts/bsdpkgpingtest
scripts/SafeFile.pm -> /scripts/SafeFile.pm
scripts/RcsRecord.pm -> /scripts/RcsRecord.pm
scripts/setupmakeconf -> /scripts/setupmakeconf
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/setupmakeconf line 8.
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/installport.pl line 15.
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/installport.pl line 15.
FATAL: rsync install failed.
Any one experience that?
 

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
Thanks as that is the first thing I intend to but after visiting that page I see this message:
]If you are the customer of a hosting company or datacenter, you need to contact them for support. This form is for datacenters and directly-licensed cPanel customers only. End users must contact their hosting company or datacenter for support as we do not have access to their servers and will be unable to assist you without their intervention.
Now I am stucked and might as well asking my client to think of other cp instead... ...
 

easyhoster1

Well-Known Member
Sep 25, 2003
656
0
166
I suggest you contact your NOC or host then, as the licence is issued to them and they can contact Cpanel to assist. We run all FREEBSD servers and never had a problem installing the builds.
 

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
I helped my client to install cpanel first then after installation my client will buy the license from one of the distributor. I have installed a few times and this is the first time I encounter such problem :( I will ask my client to contact the distributor for help. Thanks :D
 

sjackson909

Well-Known Member
Jun 8, 2004
113
0
166
Columbus, OH
Try this

rm -rf /scripts/
rm -rf /home/cpins/

cd /usr/ports/net/rsync/
make clean
make install

cd /home; mkdir cpins;cd cpins;fetch http://layer1.cpanel.net/latest;sh latest

I have ran into this problem before, I belive I just installed the rsync port manual and that resolved the issue. Let me know

Thanks
-Seth
 

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
This is what I have done.
Code:
localhost# rm -rf /home/cpins/ /scripts/
localhost# cd /usr/ports/net/rsync && make install clean distclean
localhost# cd /home; mkdir cpins;cd cpins;fetch http://layer1.cpanel.net/latest;sh latest
Same error appeared but able to continue due to like you said rsync is installed to "rsync" ... hmm...
Code:
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/setupmakeconf line 8.
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/installport.pl line 15.
Too many arguments for open at /scripts/SafeFile.pm line 67, near ""${lockfile}")"
Too many arguments for open at /scripts/SafeFile.pm line 73, near "$file)"
BEGIN failed--compilation aborted at /scripts/installport.pl line 15.
The above error still there but rsync fatal error is gone as it has been installed manually...
Code:
FATAL: rsync install failed.
Many thanks and I hope there is no error caused by those /scripts/SafeFile.pm after the installation is completed ;)
 
Last edited:

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
An update... installation still in process but here is the top result:
Code:
last pid: 56662;  load averages:  0.00,  0.04,  0.11                                                                                         up 1+00:34:25  01:16:11
119 processes: 1 running, 39 sleeping, [b]79 zombie[/b]
CPU states:  0.4% user,  0.0% nice,  0.4% system,  0.0% interrupt, 99.2% idle
Mem: 33M Active, 555M Inact, 122M Wired, 444K Cache, 112M Buf, 291M Free
Swap: 2048M Total, 2048M Free
Throughout the installation... many things failed which I am unable to get all the failed messages... but hopefully can troubleshoot after the installation is completed such as certain files or directories not found etc...
 

sjackson909

Well-Known Member
Jun 8, 2004
113
0
166
Columbus, OH
Maybe cpanel just farted somthing up on the Freebsd lastest. If I were at the office I would try and reproduce this for you.

Thanks
-Seth
 

choon

Member
PartnerNOC
Oct 27, 2001
22
0
301
Singapore
Thanks Seth ;)
Ok, here is what I know... before installing WHM/cPanel in FreeBSD-RELEASE 4.10 at least in my case, make sure the following are installed:
rsync
wget
XFree86-libraries

After installation if you find named cannot be started due to cannot read "/var/run/named.pid"... you need to edit "/etc/named.conf" file right below:
Code:
directory "/etc/namedb";
Add:
Code:
pid-file "/var/run/named/pid";
Then issue this command:
Code:
mkdir -p /var/run/named
chown -R bind:bind /var/run/named
Then restart named:
Code:
/scripts/restartsrv named
That is how I do troubleshooting in order to get all services up and running.

Many thanks for Seth's assistance :D