The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install SSL Certificate doesn't work

Discussion in 'General Discussion' started by oziris, Sep 25, 2005.

  1. oziris

    oziris Registered

    Joined:
    Aug 29, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I cannot install or update SSL certificate from WHM. After entering domain name, and clicking Fetch button, CRT, KEY, username and IP are appear. But 'Do it' button become disabled. If I delete CRT and KEY from /usr/share/ssl/certs/ and /usr/share/ssl/private/ and enter CRT and KEY, I can push Do it button, but nothing is happened. Nothing is written in the httpd.conf.
    I was trying to write httpd.conf manualy, but instead current https domain web browser shows https domain already installed.

    I have two https domains already installed (installed before half of year). Than I haven't got problems with SSL CRT installation.

    WHM 10.6.0 cPanel 10.8.0-S21

    Can somebody help?
     
  2. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hey

    Im having the same problem. When you generate the KEY file and CSR via cpanel it works fine, but doesnt show up in cpanels SSL hosts.

    SO when you try install certificate it wont let you because it cant find the KEY.

    Im running latest RELEASE.

    cheers
    Andy
     
  3. oziris

    oziris Registered

    Joined:
    Aug 29, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I do not know what is hapened, Installation just start to work. SSL domain was instaled and show up in cpanels SSL hosts.
    But, second problem still standing. Instead current https://mydomain.com web browser shows https://olddomain.com installed long time before. http://mydomain.com works, but when call https://mydomain.com, server redirect to another SSL domain. mydomain.com is standing in WHM SSL hosts.
     
  4. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hey

    check what ip address its using in the "List domains" page in cpanel and also in the apache config file.

    It might be redirecting to the old server.

    cheers
    Andy
     
Loading...

Share This Page