The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Install SSL on hostname: The system failed to find an owner for the domain “mydomain.com"

Discussion in 'General Discussion' started by afunworm, Nov 16, 2014.

  1. afunworm

    afunworm Member

    Joined:
    Nov 16, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all.

    I have a domain mydomain.com.

    Under WHM>Service Configuration>Manage Service SSL Certificates, I installed SSL for my main domain (but under sub-domain) secure.mydomain.com for Dovecot Mail Server, Exim (SMTP) Server, FTP Server and cPanel/WHM/Webmail Service.

    But now I'd like to install another SSL Certificate for my domain (without sub-domain). I bought SSL certificate for mydomain.com, and when I tried to install it, I receive the following error:

    The system failed to find an owner for the domain “mydomain.com"

    I tried:
    Code:
    mv /var/cpanel/users/system /root/
    And received the following error:
    Code:
    mv: cannot stat `/var/cpanel/users/system': No such file or directory
    When I run:
    Code:
    /scripts/updateuserdomains
    I didn't receive any error.

    I'm running CentOS 6 on WHM VPS Optimize.

    Please advise,

    Thank you :).
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Does an account exist for this domain name? If so, is the correct username reflected when running the "/scripts/whoowns $domain" command? What method are you using to install it, and what version of cPanel is installed on your system?

    Thank you.
     
  3. afunworm

    afunworm Member

    Joined:
    Nov 16, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    "/scripts/whoowns mydomain.com" returns blank, I believe there is no owner for this account. However, I DID create an account from WHM by going through: WHM > Account Functions > Create a New Account. The account's domain is the main and only domain as of now for the domain I'd like to install SSL on, e.g. mydomain.com. That was the first thing I did when started up cPanel. I still am not able to install SSL on mydomain.com (even though I installed secure.mydomain.com without any hassle). If that is not the account owner, what else is?

    Please advise,

    Thank you :).
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page