Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Installation error for mysql .sock file on centos 4.2

Discussion in 'General Discussion' started by WebHostPro, Feb 8, 2006.

  1. WebHostPro

    WebHostPro Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,660
    Likes Received:
    16
    Trophy Points:
    318
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Twitter:
    Here is the error:

    mysqladmin: connect to server at 'localhost' failed
    error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)'
    Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists!


    I have a removed and re-installed mysql and I have created the sock file but it gets removed some how, and Mysql will not start.

    Thanks, Charles
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. WebHostPro

    WebHostPro Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,660
    Likes Received:
    16
    Trophy Points:
    318
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Twitter:
    I see you need to upgrade to mysql 4.1 when using centos 4.2 :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    168
    Where does it say that? (I'm not running CentOS 4.2 currently, but will be switching to CentOS)
     
  4. WebHostPro

    WebHostPro Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,660
    Likes Received:
    16
    Trophy Points:
    318
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Twitter:
    Doesn't say that, but upgrading is what made it work after trying everything else suggested.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice