Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Installation - httpupdate failed

Discussion in 'General Discussion' started by sclayton, Jun 27, 2005.

  1. sclayton

    sclayton Member

    Joined:
    Jun 15, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    UK
    Hi

    during installation of cpanel 'sh latest' I get the following errors:

    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/cpanel.tar.bz2....Trying httpupdate.cpanel.net @ 69.72.164.152
    1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...
    20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...
    34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...
    48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...Unable to retrieve file
    ...Failed
    wall: can't read cPanel Layer 2 Install Commencing.


    I have tried the installation several tmes and it always fails at this point and always at 58% of the download. cpanel.tar.bz2 is being downloaded into /usr/local and its filesize after the error occurs is always:

    -rw-r--r-- 1 root root 10084352 Jun 27 16:16 cpanel.tar.bz2

    I am trying to install on suSE 8.2, first thoughts were that it must be an OS filesize limit but
    running 'ulimit -a' shows that filesize is unlimited.

    I am also seeing the following types of errors, but they don't seem to be causing any
    particular problems, but I might be wrong!

    Building Apache../...Done
    Waiting for perl module install to complete...\Done
    Installing Startup Scripts...Importing sys mods.....Done
    Done
    Repairing Common Problems (this might take a while)..../Done
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "en_GB",
    LANG = "C"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:


    cpsrvd does not exist anywhere on the system, but I guess this is because the install
    in bailing out.


    Any help greatly appreciated.
     
    #1 sclayton, Jun 27, 2005
    Last edited: Jun 27, 2005
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Did you definitely do a minimal OS installation before installing cPanel? Often the cause of such problems can be from full server OS installations where there are conflicting apps installed.

    If you did do a minimal install, I'd suggest logging a support ticket directly with cPanel since it is a new installation, at:
    https://tickets.cpanel.net/submit/index.cgi?support=1
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sclayton

    sclayton Member

    Joined:
    Jun 15, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Location:
    UK
    Hi

    I did do a minimal install but found that I needed to also install the following packages before 'sh latest' would begin to run:

    bind9
    wget
    binutils
    python
    gcc
    utoconf
    automake
    make
    g++
    rpm –install rcd-2.2.0-0.ximian.7.5.i586.rpm
    rpm –install rug-2.2.0-0.ximian.7.0.i586.rpm

    regards
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice