Installation Problems - Can't locate Cwd.pm

HelloAdam

Well-Known Member
Nov 6, 2005
145
0
166
Hey,

I was installing cPanel today and when running sh latest I got this message,

Can't locate Cwd.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl . ./scripts) at /scripts/cPScript/cPanelFunctions.pm line 13.
BEGIN failed--compilation aborted at /scripts/cPScript/cPanelFunctions.pm line 13.
Compilation failed in require at /scripts/cPScript/DnsRoots.pm line 15.
BEGIN failed--compilation aborted at /scripts/cPScript/DnsRoots.pm line 15.
Compilation failed in require at scripts/cPScript/HttpRequest.pm line 16.
BEGIN failed--compilation aborted at scripts/cPScript/HttpRequest.pm line 16.
Compilation failed in require at /home/cpins/installd/perlbootstrap line 23.
BEGIN failed--compilation aborted at /home/cpins/installd/perlbootstrap line 23.

cPanel showed that a few times and then secured my /tmp folder and said everything went okay. I tried running /scripts/upcp --force and got the same thing.

Any ideas?

From,
Adam
 
Last edited:

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
Hey,

I was installing cPanel today and when running sh latest I got this message,

Can't locate Cwd.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl . ./scripts) at /scripts/cPScript/cPanelFunctions.pm line 13.
BEGIN failed--compilation aborted at /scripts/cPScript/cPanelFunctions.pm line 13.
Compilation failed in require at /scripts/cPScript/DnsRoots.pm line 15.
BEGIN failed--compilation aborted at /scripts/cPScript/DnsRoots.pm line 15.
Compilation failed in require at scripts/cPScript/HttpRequest.pm line 16.
BEGIN failed--compilation aborted at scripts/cPScript/HttpRequest.pm line 16.
Compilation failed in require at /home/cpins/installd/perlbootstrap line 23.
BEGIN failed--compilation aborted at /home/cpins/installd/perlbootstrap line 23.

cPanel showed that a few times and then secured my /tmp folder and said everything went okay. I tried running /scripts/upcp --force and got the same thing.

Any ideas?

From,
Adam


What does

/scripts/perlinstaller --force Cwd

show ?
 

HelloAdam

Well-Known Member
Nov 6, 2005
145
0
166
Hey,

I think the cPanel techs fixed this. Not sure how or what they did. But I can now login to /whm and see the wonderful green screen that shows Apache is installed :)

Thanks for your help,
Adam
 

kiwiroll

Member
Jun 5, 2006
16
0
151
Japan
please help me!!!

run : /scripts/perlinstaller --force

Can't locate File/Spec/Functions.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /scripts/cPScript/cPanelFunctions.pm line 13.
BEGIN failed--compilation aborted at /scripts/cPScript/cPanelFunctions.pm line 13.
Compilation failed in require at /scripts/cPScript/DnsRoots.pm line 15.
BEGIN failed--compilation aborted at /scripts/cPScript/DnsRoots.pm line 15.
Compilation failed in require at /scripts/cPScript/HttpRequest.pm line 16.
BEGIN failed--compilation aborted at /scripts/cPScript/HttpRequest.pm line 16.
Compilation failed in require at /scripts/cPScript/cPCPAN.pm line 10.
BEGIN failed--compilation aborted at /scripts/cPScript/cPCPAN.pm line 10.
Compilation failed in require at /scripts/perlinstaller line 8.
BEGIN failed--compilation aborted at /scripts/perlinstaller line 8.



run : /scripts/perlinstaller --force Cwd

Can't locate File/Spec/Functions.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /scripts/cPScript/cPanelFunctions.pm line 13.
BEGIN failed--compilation aborted at /scripts/cPScript/cPanelFunctions.pm line 13.
Compilation failed in require at /scripts/cPScript/DnsRoots.pm line 15.
BEGIN failed--compilation aborted at /scripts/cPScript/DnsRoots.pm line 15.
Compilation failed in require at /scripts/cPScript/HttpRequest.pm line 16.
BEGIN failed--compilation aborted at /scripts/cPScript/HttpRequest.pm line 16.
Compilation failed in require at /scripts/cPScript/cPCPAN.pm line 10.
BEGIN failed--compilation aborted at /scripts/cPScript/cPCPAN.pm line 10.
Compilation failed in require at /scripts/perlinstaller line 8.
BEGIN failed--compilation aborted at /scripts/perlinstaller line 8.

help me...
 

kiwiroll

Member
Jun 5, 2006
16
0
151
Japan
You should upgrade Perl to v5.8.8. Here is HowTo: http://servertune.com/kbase/?View=entry&EntryID=132

thank you very much . but


wget http ://layer1.cpanel.net/perl588installer.tar.gz
./install


↓ endless error


System call "/usr/bin/wget -O - "http://69.90.250.34/pub/CPAN/authors/id/cPCPAN/P/PM/PMQS/Compress-Zlib [-] 1.42 [.] tar.gz" > /home/.cpan/sources/authors/id/cPCPAN/P/PM/PMQS/Compress-Zlib [-] 1.42 [.] tar"
returned status 1 (wstat 256)
Warning: expected file [/home/.cpan/sources/authors/id/cPCPAN/P/PM/PMQS/Compress-Zlib [-] 1.42 [.] tar.gz] doesn't exist

Trying with "/usr/bin/wget -O -" to get
http://69.90.250.35/pub/CPAN/authors/id/cPCPAN/P/PM/PMQS/Compress-Zlib [-] 1.42 [.] tar.gz

Warning: wildcards not supported in HTTP.
--13:47:53-- http://69.90.250.35/pub/CPAN/authors/id/cPCPAN/P/PM/PMQS/Compress-Zlib [-]%201.42%20[.]%20tar.gz
=> `-'
Connecting to 69.90.250.35:80... connected.
HTTP request sent, awaiting response... 404 Not Found
13:47:53 ERROR 404: Not Found.

http://[-]: Invalid IPv6 numeric address.
--13:47:53-- http://1.42/
=> `-'
Resolving 1.42... 1.0.0.42
Connecting to 1.42|1.0.0.42|:80... failed: Connection timed out.
Retrying.

--13:48:39-- http://1.42/
(try: 2) => `-'
Connecting to 1.42|1.0.0.42|:80... failed: Connection timed out.
Retrying.

--13:49:26-- http://1.42/
(try: 3) => `-'



please help ...:confused: