The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installation problems

Discussion in 'Database Discussions' started by Corrado, May 19, 2005.

  1. Corrado

    Corrado Member

    Joined:
    May 3, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I have been testing with RHE en cpanel.

    First of all I installed my server with RHE 3.0 SE:

    question 1 : should I turn on the firewall or not ?

    after installation of RHE, I installed cPanel, but exim dit not install and apache web server would not start up. I reinstalled (clean install) RHE en cPanel 3 times, always the same problem.

    Question2: what am I doing wrong ?

    Second I installed RHE 4.0 SE:

    after installation of RHE, I installed cPanel, but exim did not install and mysql wouldn't start up. Apache web server is ok now. Again I did the installation 2 times, but always the same result.

    question 3: what should I do to get exim and eximstats running ?
    question 4: is my basic installation of RHE wrong ?

    Advice is welcome !

    Stefan
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    disable firewall. cpanel script might be having a hard time getting the required files.

    also eximstats will work only when mysql is up. In any case i guess your firewall is the culprit.
     
  3. Corrado

    Corrado Member

    Joined:
    May 3, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I always installed RHE with firewall off ! So cPanel scripts shouldn't have a problem downloading the things they need.
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    can u try downloading any package with the wget command from shell ?

    also you can try an

    #iptables -F

    from shell and then try the upcp.
     
  5. Corrado

    Corrado Member

    Joined:
    May 3, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I'll try this tonight, I'm not at the server right now.

    Anybody an idea why exim won't install at all ?

    Should this be installed by cPanel install or should I do this manually ?
     
  6. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    please do this. exim shld be installed by C-panel as well.
     
  7. Corrado

    Corrado Member

    Joined:
    May 3, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
  8. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    /scripts/mysqlup

    did u try that ?
     
  9. Corrado

    Corrado Member

    Joined:
    May 3, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    indeed, but that didn't solve the problem, so I went to tweak settings and upgraded the SQL to version 4.1 After cPanel downloading some stuff and installing mysql, it worked fine, the only thing now that won't startup yet is eximstats. I'm not sure but i think it has something to do with a non existing database in mysql needed for exemstats. Did /scripts/eximup -- force, but that did nothing to eximstats.
     
Loading...

Share This Page