Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Installed SSL for hostname and starting gertting error on IP access

Discussion in 'Security' started by postcd, Feb 12, 2016.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    694
    Likes Received:
    15
    Trophy Points:
    68
    Hello,

    when accessing WHM using web browser using address with server hostname i was getting SSL insecure error.

    So i got CA veriffied SSL for WHM server hostname and now i started getting SSL insecure error when accessing WHM via IP like on image below. i only masked IP occurences.

    ssl_error_on_IP.gif

    I wanted to ask how people can stop getting this "connection is not private error". By installing SSL for hostname i anyhow removed self signed SSL for IP? How i can have both at a time?

    I installed hostame SSL from within Home »Service Configuration »Manage Service SSL Certificates

    (during installation selected all tickboxes):
    - Calendar, cPanel, WebDisk, Webmail, and WHM Services
    - Dovecot Mail Server
    - Exim (SMTP) Server
    - FTP Server


    thank you for advices
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,861
    Likes Received:
    89
    Trophy Points:
    78
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Do you mean you have installed SSL certificate for cPanel services and you are still getting this self signed ssl warning ?

    If you have installed SSL on your hosname then you can verify that through WHM >> Service Configuration >> Manage Service SSL Certificates >> Certificate Details
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    694
    Likes Received:
    15
    Trophy Points:
    68
    In my initial post i tried to mention that https connection started working via hostname, but when using IP instead of hostname, im receiving warning as per the screenshot. Please reply only if you have solution on how to make working https for both (hostname and IP), thank you alot
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #3 postcd, Feb 12, 2016
    Last edited: Feb 12, 2016
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    The redirect options for SSL under the "Redirection" tab in "WHM >> Tweak Settings" do not apply when accessing the port directly. The warning you noted is normal because the IP address does not match the certificate name. You should access cPanel/WHM via the SSL certificate name, or through the "/cpanel" and "/whm" URLs if you have configured redirection options in "WHM >> Tweak Settings".

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    694
    Likes Received:
    15
    Trophy Points:
    68
    Thank You for helpfull advices Michael

    Yes, i configured like this:
    (beside "Hostname" i also tried "Origin Domain Name" and "SSL Certificate Name")

    But when i access:

    https://WHMIPHERE/cpanel

    im not redirected from IP to hostname or anywere.

    Do i need to restart any service or clear some cpanel cache? Im using Firefox, and i tried also Chrome to make sure its not browser issue.

    btw: any hack to redirect from https://WHMIPHERE:2083 to https://WHMIPHERE/cpanel to prevent scaring users with insecure messages?

    thank you
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    1. Could you try saving the options under "WHM >> Tweak Settings" again to see if that helps? I'm unable to reproduce the issue.

    2. There are no native features that will redirect users who access cPanel with the port number to another URL.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    694
    Likes Received:
    15
    Trophy Points:
    68
    RE Michael
    1) no, not helped. only http://IP/whm and http://IP/cpanel is redirected to hostname. httpS is not redirected (tried firefox & chrome)
    2) i know, i already searched on the forums, i was looking for a workaround
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,749
    Likes Received:
    1,885
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Feel free to open a support ticket using the link in my signature so we can attempt to determine why it's not functioning as expected. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice