The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installer Problems...

Discussion in 'General Discussion' started by HollyRidge, Apr 26, 2003.

  1. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Have an install problem here on a server... Anyone know why this is doing this (timeout)?? I can connect to the file directly from the pc I am using to install it from but wont install. (Sorry had to post in 2 post due to length.)

    root@cpanel [/home/installd]# ./install
    cPanel [5.0] Layer 1 Installer Init.....
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    -------------------------------------------------------
    cPanel requires a fresh/clean server!
    If you are serving websites off this server (and are
    not already running cPanel) this installer will
    overwrite all of your config files. You should hit
    Ctrl+C NOW!!!
    If this is a new server please ignore this messages
    -------------------------------------------------------
    Warning !!! Warning !!! WARNING !!! Warning !!! Warning
    Waiting 5 seconds.....
    Done
    This install will take 10-70 minutes depending on your hardware.
    Now is the time to go get another cup of coffee/jolt.
    The install will log to /var/log/cp4install.log.
    Repairing OS Problems....Done
    Installing Default resolv.conf....Done
    Installing Support Libs.Loading rpm update cache...
    libtool is up to date
    Loading rpm update cache...
    autoconf is up to date
    Loading rpm update cache...
    automake is up to date
    Loading rpm update cache...
    perl-CPAN is up to date
    Loading rpm update cache...
    perl-CGI is up to date
    Loading rpm update cache...
    Attempting to install compat-db
    Loading rpm update cache...
    Attempting to install openssl095a
    Loading rpm update cache...
    glibc-kernheaders is up to date
    Loading rpm update cache...
    Attempting to install kernel-headers
    Loading rpm update cache...
    binutils is up to date
    Loading rpm update cache...
    wget is up to date
    Loading rpm update cache...
    bzip2 is up to date
    Loading rpm update cache...
    Attempting to install expect
    Loading rpm update cache...
    gdbm is up to date
    Loading rpm update cache...
    gdbm-devel is up to date
    Loading rpm update cache...
    Attempting to install imap
    Loading rpm update cache...
    Attempting to install imap-devel
    Loading rpm update cache...
    Attempting to install ncurses4
    Loading rpm update cache...
    Attempting to install ncurses3
    Loading rpm update cache...
    passwd is up to date
    Loading rpm update cache...
    pwdb is up to date
    Loading rpm update cache...
    shadow-utils is up to date
    Loading rpm update cache...
    tcl is up to date
    Loading rpm update cache...
    Attempting to install tclx
    Loading rpm update cache...
    Attempting to install tix
    Loading rpm update cache...
    Attempting to install tk
    Loading rpm update cache...
    Attempting to install tkinter
    Loading rpm update cache...
    python is up to date
    Loading rpm update cache...
    python-devel is up to date
    Loading rpm update cache...
    Attempting to install python-docs
    Loading rpm update cache...
    Attempting to install python-tools
    Loading rpm update cache...
    rdate is up to date
    Loading rpm update cache...
    cpio is up to date
    Loading rpm update cache...
    popt is up to date
    Loading rpm update cache...
    ncurses is up to date
    Loading rpm update cache...
    ncurses-devel is up to date
    Loading rpm update cache...
    zlib is up to date
    Loading rpm update cache...
    zlib-devel is up to date
    Loading rpm update cache...
    Attempting to install lynx
    Loading rpm update cache...
    freetype is up to date
    Loading rpm update cache...
    Attempting to install freetype-devel
    Loading rpm update cache...
    rcs is up to date
    Loading rpm update cache...
    gd is up to date
    Loading rpm update cache...
    gd-devel is up to date
    Loading rpm update cache...
    flex is up to date
    Loading rpm update cache...
    bison is up to date
    Loading rpm update cache...
    glibc-devel is up to date
    Loading rpm update cache...
    gcc is up to date
    Loading rpm update cache...
    gcc-c++ is up to date
    Loading rpm update cache...
    cpp is up to date
    Loading rpm update cache...
    libstdc++ is up to date
    Loading rpm update cache...
    libjpeg is up to date
    Loading rpm update cache...
    libjpeg-devel is up to date
    Loading rpm update cache...
    libpng is up to date
    Loading rpm update cache...
    libpng-devel is up to date
    Loading rpm update cache...
    libtiff is up to date
    Loading rpm update cache...
    libtiff-devel is up to date
    Loading rpm update cache...
    rsync is up to date
    Loading rpm update cache...
    Attempting to install libgdbm2-devel
    Loading rpm update cache...
    db1 is up to date
    Loading rpm update cache...
    db1-devel is up to date
    Loading rpm update cache...
    Attempting to install db1-tools
    Loading rpm update cache...
    Attempting to install db4
    Loading rpm update cache...
    Attempting to install db4-devel
    Done
    Syncing with time server......Sat Apr 26 17:02:28 BST 2003..Done
    Rsyncing with rsync.cpanel.net....Done
    Ensuring /etc/passwd is shadowed...Done
    Removing incompatible rpms....Done
    Setting Permissions and shells...Done
    Installing jre,jdk........-....Done
    Removing previous CPAN settings....Done
    Upgrading perl..|Done
    Installing cPanel Specific RPMS...Unable to retrieve file
    Using Mysql4
    Loading rpm update cache...
    pine is up to date
    Loading rpm update cache...
    gd is up to date
    Loading rpm update cache...
    gd-devel is up to date
    Loading rpm update cache...
    Attempting to install gd-progs
    Loading rpm update cache...
    Attempting to install expect
    Loading rpm update cache...
    freetype is up to date
    Loading rpm update cache...
    Attempting to install freetype-devel
    Loading rpm update cache...
    gnupg is up to date
    Loading rpm update cache...
    Attempting to install lynx
    Loading rpm update cache...
    ucd-snmp is up to date
    Loading rpm update cache...
    Attempting to install ucd-snmp-devel
    Loading rpm update cache...
    ucd-snmp-utils is up to date
    Loading rpm update cache...
    wget is up to date
    Loading rpm update cache...
    sharutils is up to date
    Loading rpm update cache...
    bind is up to date
    Loading rpm update cache...
    bind-utils is up to date
    Loading rpm update cache...
    openssl is up to date
    Loading rpm update cache...
    openssl-devel is up to date
    Loading rpm update cache...
    Attempting to install openssl-misc
    Loading rpm update cache...
    openssh is up to date
    Loading rpm update cache...
    openssh-server is up to date
    Loading rpm update cache...
    openssh-clients is up to date
    Loading rpm update cache...
    Attempting to install XFree86-devel
    Loading rpm update cache...
    Attempting to install XFree86-libs
    ...Done
    Installing OS Specific RPM errata....Unable to retrieve file
    ...Done
    Installing frontpage ..-...Done
    Building Apache..\...Done
    Installing Startup Scripts.../etc/rc.d/init.d/httpd stop: httpd stopped
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    [Sat Apr 26 17:19:28 2003] [warn] NameVirtualHost 12.34.56.78:80 has no VirtualHosts
    /etc/rc.d/init.d/httpd start: httpd started
    Importing sys mods.....Done
    Done
    Repairing Common Problems.....Done
    All done
    Please wait while the temp files are cleaned up..........PHP version file is up to date
    Doing a manual update...
    Cpanel updates are coming from layer2.cpanel.net
    Sent kernelcheck mail
    passwd: Unknown user name 'xfs'.
    Locking password for user daemon.
    passwd: Success
    Unable to retrieve file
    SENT ipcheck email
    x - creating lock directory
    x - SKIPPING /usr/local/lib/php.ini (file already exists)
    Unable to retrieve file
    Using Mysql4
    Loading rpm update cache...
    pine is up to date
    Loading rpm update cache...
    gd is up to date
    Loading rpm update cache...
    gd-devel is up to date
    Loading rpm update cache...
    Attempting to install gd-progs
    Loading rpm update cache...
    Attempting to install expect
    Loading rpm update cache...
    freetype is up to date
    Loading rpm update cache...
    Attempting to install freetype-devel
    Loading rpm update cache...
    gnupg is up to date
    Loading rpm update cache...
    Attempting to install lynx
    Loading rpm update cache...
    ucd-snmp is up to date
    Loading rpm update cache...
    Attempting to install ucd-snmp-devel
    Loading rpm update cache...
    ucd-snmp-utils is up to date
    Loading rpm update cache...
    wget is up to date
    Loading rpm update cache...
    sharutils is up to date
    Loading rpm update cache...
    bind is up to date
    Loading rpm update cache...
    bind-utils is up to date
    Loading rpm update cache...
    openssl is up to date
    Loading rpm update cache...
    openssl-devel is up to date
    Loading rpm update cache...
    Attempting to install openssl-misc
    Loading rpm update cache...
    openssh is up to date
    Loading rpm update cache...
    openssh-server is up to date
    Loading rpm update cache...
    openssh-clients is up to date
    Loading rpm update cache...
    Attempting to install XFree86-devel
    Loading rpm update cache...
    Attempting to install XFree86-libs
    Unable to retrieve file
     
  2. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Part 2

    chattr: No such file or directory while trying to stat /etc/chkserv.d
    Unable to retrieve file
    Using Mysql4
    Loading rpm update cache...
    pine is up to date
    Loading rpm update cache...
    gd is up to date
    Loading rpm update cache...
    gd-devel is up to date
    Loading rpm update cache...
    Attempting to install gd-progs
    Loading rpm update cache...
    Attempting to install expect
    Loading rpm update cache...
    freetype is up to date
    Loading rpm update cache...
    Attempting to install freetype-devel
    Loading rpm update cache...
    gnupg is up to date
    Loading rpm update cache...
    Attempting to install lynx
    Loading rpm update cache...
    ucd-snmp is up to date
    Loading rpm update cache...
    Attempting to install ucd-snmp-devel
    Loading rpm update cache...
    ucd-snmp-utils is up to date
    Loading rpm update cache...
    wget is up to date
    Loading rpm update cache...
    sharutils is up to date
    Loading rpm update cache...
    bind is up to date
    Loading rpm update cache...
    bind-utils is up to date
    Loading rpm update cache...
    openssl is up to date
    Loading rpm update cache...
    openssl-devel is up to date
    Loading rpm update cache...
    Attempting to install openssl-misc
    Loading rpm update cache...
    openssh is up to date
    Loading rpm update cache...
    openssh-server is up to date
    Loading rpm update cache...
    openssh-clients is up to date
    Loading rpm update cache...
    Attempting to install XFree86-devel
    Loading rpm update cache...
    Attempting to install XFree86-libs
    CPAN: Storable loaded ok
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
    http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    LWP failed with code[500] message[Can't connect to ftp.cpanel.net:80 (Timeout)]

    Trying with "/usr/bin/lynx -source" to get
    http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    sh: /usr/bin/lynx: No such file or directory

    System call "/usr/bin/lynx -source 'http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz' > /root/.cpan/sources/authors/01mailrc.txt"
    returned status 127 (wstat 32512)
    Warning: expected file [/root/.cpan/sources/authors/01mailrc.txt.gz] doesn't exist

    Trying with "/usr/bin/ncftpget" to get
    http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz


    System call "cd /root/.cpan/sources/authors && /usr/bin/ncftpget 'http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz' "
    returned status 8 (wstat 2048)
    Warning: expected file [/root/.cpan/sources/authors/01mailrc.txt.gz] doesn't exist

    Trying with "/usr/bin/wget -O -" to get
    http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    --17:33:08-- http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    => `-'
    Resolving ftp.cpanel.net... done.
    Connecting to ftp.cpanel.net[216.118.116.104]:80... failed: Connection timed out.
    Retrying.

    --17:36:18-- http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    (try: 2) => `-'
    Connecting to ftp.cpanel.net[216.118.116.104]:80... failed: Connection timed out.
    Retrying.

    --17:39:29-- http://ftp.cpanel.net/pub/CPAN/authors/01mailrc.txt.gz
    (try: 3) => `-'
    Connecting to ftp.cpanel.net[216.118.116.104]:80... failed: Connection timed out.
    Retrying.



    This just keeps going and going.....
     
  3. SoftmegUK

    SoftmegUK Well-Known Member

    Joined:
    Feb 13, 2002
    Messages:
    372
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    Are there ports closed in the firewall and have you checked the network card is working correctly....
     
  4. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    No firewall...

    root@cpanel [/etc/sysconfig]# iptables -L -n
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    root@cpanel [/etc/sysconfig]#


    Also I am able to connect to the default web page which since is also on port 80 this is really blowing my mind here too.

    I also tried pinging out of the server as well as to it. The same thing with trace routes. I can telnet out of it and ssh to it. I know those are on different ports and types but kinda helps show its not being hidden.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    can you ping rsync.cpanel.net and ftp.cpanel.net

    does ftping to ftp.cpanel.net work?

    does
    rsync -av rsync://rsync.cpanel.net/scripts /scripts

    work ?
     
  6. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Everything there worked with good response. Here are the results...

    root@cpanel [/etc/sysconfig]# ping rsync.cpanel.net
    PING rsync.cpanel.net (66.197.217.12) from 12.34.56.78: 56(84) bytes of data.
    64 bytes from 66.197.217.12: icmp_seq=1 ttl=240 time=77.6 ms
    64 bytes from 66.197.217.12: icmp_seq=2 ttl=240 time=78.6 ms
    64 bytes from 66.197.217.12: icmp_seq=3 ttl=240 time=78.0 ms

    --- rsync.cpanel.net ping statistics ---
    3 packets transmitted, 3 received, 0% loss, time 2020ms
    rtt min/avg/max/mdev = 77.639/78.142/78.697/0.433 ms
    root@cpanel [/etc/sysconfig]#


    root@cpanel [/etc/sysconfig]# ping ftp.cpanel.net
    PING diffusion.cpanel.net (216.118.116.104) from 12.34.56.78: 56(84) bytes of data.
    64 bytes from diffusion.cpanel.net (216.118.116.104): icmp_seq=1 ttl=242 time=76.5 ms
    64 bytes from diffusion.cpanel.net (216.118.116.104): icmp_seq=2 ttl=242 time=77.2 ms
    64 bytes from diffusion.cpanel.net (216.118.116.104): icmp_seq=3 ttl=242 time=76.3 ms

    --- diffusion.cpanel.net ping statistics ---
    3 packets transmitted, 3 received, 0% loss, time 2015ms
    rtt min/avg/max/mdev = 76.365/76.726/77.282/0.458 ms
    root@cpanel [/etc/sysconfig]#


    root@cpanel [/etc/sysconfig]# rsync -av rsync://rsync.cpanel.net/scripts /scripts
    receiving file list ... done
    ./
    wrote 71 bytes read 5956 bytes 4018.00 bytes/sec
    total size is 2609117 speedup is 432.90
    root@cpanel [/etc/sysconfig]#


    And on ftping into cpanel (It answers but didnt know what to use for user/pw)...
    root@cpanel [/etc/sysconfig]# ftp
    ftp> open ftp.cpanel.net
    Connected to ftp.cpanel.net (216.118.116.104).
    220 Linux 2.4 TUX 2.0 FTP server welcomes you!
    Name (ftp.cpanel.net:root): Anonoymous
    530 Sorry, Login Denied!
    Login failed.
    421 Service not available, remote server has closed connection
    ftp> !
    root@cpanel [/etc/sysconfig]#


    (I tried logging in with Anonymous but it denied me)
     
    #6 HollyRidge, Apr 26, 2003
    Last edited: Apr 26, 2003
  7. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Anyone have any ideas???

    This is still doing this... I let it run last night over night until it just cancelled itself after 20 tries.
     
  8. kes

    kes Registered

    Joined:
    Apr 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    This problem has also been entered as a support ticket [Eric and Chris] but no has bothered to enven log into the server from cPanel. Its been logged as asupport issue for over a week. The *only* feedback I've gotten is "Are you trying to install...." DOH!

    Now the web based ticketing support page now gives me an error when I connect so that is knackered also. Seems to be a theme here.

    So what kind of support do you guys actually provide at CPanel? This is a very fair question as you don't seem to know wtf is going with your own install and don't reply to emails or provide a stable web based support ticketing system.

    So wtf do you actually do please as you are pissing me off bigtime :(

    kes
     
  9. HollyRidge

    HollyRidge Well-Known Member

    Joined:
    Feb 25, 2003
    Messages:
    138
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Garner NC USA
    cPanel Access Level:
    Root Administrator
    Same experiences for me kes. I probably shouldnt say this but the support we have recieved through cpanel is pretty awful.

    I submitted a trouble ticket about a server hanging while performing updates which it would just hang on certain processes such as trying to uninstall mysql rpms and sit there with the load sky rocketting even so high I had to contact the datacenter to have them reboot it manually so that I could get back in. They promptly replied back with in a few hours asking for login info which I immediatly responded back thinking hey they gonna get me all fixed up now. Boy was I wrong! I waited for 4 days and then still no response so I contacted the phone number on the ticket which the person I spoke with pretty much acted like they could care less and even hung up on me right while I was in the middle of asking them a question. He kept telling me they were looking into it. Yeah the only one that had logged into the server was me! Finally after about the 5th day I got someone to take a look at the server and replied back saying I gave them the wrong login info which the info I gave them was correct. I responded back asking them to try again as it was right. They finally got around to trying it again and guess what... they got in with the same info and finally got it resolved.

    Now luckily the customer was very understanding and patient through the whole process but he just purchased this server and he was paying for it all along and couldnt even use it for a week due to Cpanel support dragging their feet. Most customers wouldnt have been so nice.

    Then we go and try to help kes out and same thing here. I posted about this issue a week ago. I got a few responses about checking some general simple things are ok. Now this thread has been sitting here dead for about a week as well with and still no resolution.
     
  10. kes

    kes Registered

    Joined:
    Apr 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Still no replies. Still no ssh login to the server recorded. Still the web based support ticket is knackered

    No suprise there then - par for the course with cPanel it seems:(

    Probably the worst support I've (n)ever had.
     
  11. kes

    kes Registered

    Joined:
    Apr 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Still nothing.

    Amazing!
     
  12. willshoe

    willshoe Registered

    Joined:
    Sep 24, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    im also having install issues (repairing common problems) stuck...

    I do have a server on serverr beach and also had e-mail issues that went through the long wait for someone to fix the problem... I also went through the so called no one can login to the root but I could from 3 different locations... went ahead and changed my password and re-mailed it and finally after 5 days got someone to look at the problem and was fixed....but broke the addres book along the way... have to make another ticket now I guess...

    But anyway im trying to setup a server at my office instead of offsite at server beach (since I have never got a response from them with the exception of one time to call cpanel its their problem....). boy I luv just playing the pass the buck games. since I have a T1 with 13 ip's I figured it would be simplier to have my own hardware setup and take out the middle man and deal with cpanel since thats all server beach would do anyway is point the finger.

    so now I cant get this stinking app to install....firewall disabled...wide open to the damn net...

    (huff huff)...

    O well got a new server coming from IBM... we will see if I continue to have the same problems...

    P.S. I have requested a 15 day trial 2 days ago....anyone home? everyone laid off? too many problems to fix? everyone quit out of frustration? I know the feeling...
     
Loading...

Share This Page