The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Bugzilla/Perl stuff problems

Discussion in 'General Discussion' started by Daniele.Gri, Apr 9, 2010.

  1. Daniele.Gri

    Daniele.Gri Member

    Joined:
    Apr 9, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    As per topic, I'm trying to install Bugzilla on a cPanel account.

    My main problem is that there's nothing in the error log and when visiting the page I get a 500 Internal Server Error page.
    And that's kind of a show stopper.

    Where can I find more information to debug this issue?
     
    #1 Daniele.Gri, Apr 9, 2010
    Last edited: Apr 9, 2010
  2. cPanelJamyn

    cPanelJamyn Social Engineer
    Staff Member

    Joined:
    Jan 29, 2009
    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    0
    Typically, 500 'internal server errors' are caused because:

    a) permissions are bad on your public_html files/folders
    b) ownership is bad on your public_html files/folders
    c) bad directives in public_html/.htaccess or similar

    Regardless, the server's /usr/local/apache/logs/error_log will indicate the cause of the problem in much more detail for you, which should make it simple to track down.
     
  3. Daniele.Gri

    Daniele.Gri Member

    Joined:
    Apr 9, 2010
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Checking /usr/local/apache/logs/error_log via ssh helped a lot (I ran Main >> Security Center >> Fix Insecure Permissions (Scripts) and it helped immensely) but now I'm stuck with a weird error,
    (13)Permission denied: /home/----/subdomains/bugzilla/public_html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

    I tried to chmod the .htaccess file (is that even a smart thing to do?) but to no avail any further clues?

    P.S.:

    Nevermind, it was just a matter of setting $use_suexec = 1; and running ./checksetup.pl to fix stuff.
     
    #3 Daniele.Gri, Apr 10, 2010
    Last edited: Apr 10, 2010
Loading...

Share This Page