The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Cacti Issues

Discussion in 'General Discussion' started by harsharajsharma, Jun 28, 2012.

Thread Status:
Not open for further replies.
  1. harsharajsharma

    harsharajsharma Registered

    Joined:
    Jun 13, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I tried installing Cacti in my cPanel server and got the following error.

    Code:
    # yum install cacti
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.as24220.net
    * extras: mirror.as24220.net
    * rpmforge: mirror.hmc.edu
    * updates: mirror.as24220.net
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package cacti.noarch 0:0.8.8a-1.el6.rf will be installed
    --> Processing Dependency: webserver for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: net-snmp-utils for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php-snmp for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php-mysql for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Running transaction check
    ---> Package cacti.noarch 0:0.8.8a-1.el6.rf will be installed
    --> Processing Dependency: webserver for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php-snmp for package: cacti-0.8.8a-1.el6.rf.noarch
    --> Processing Dependency: php-mysql for package: cacti-0.8.8a-1.el6.rf.noarch
    ---> Package net-snmp-utils.x86_64 1:5.5-37.el6_2.1 will be installed
    --> Finished Dependency Resolution
    Error: Package: cacti-0.8.8a-1.el6.rf.noarch (dag)
    Requires: php-mysql
    Error: Package: cacti-0.8.8a-1.el6.rf.noarch (dag)
    Requires: php
    Error: Package: cacti-0.8.8a-1.el6.rf.noarch (dag)
    Requires: php-snmp
    Error: Package: cacti-0.8.8a-1.el6.rf.noarch (dag)
    Requires: webserver
    You could try using --skip-broken to work around the problem
    
    All the ser vices are installed but not sure how to troubleshoot it.
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You are probably going to have to remove php* from /etc/yum.conf file as an exclusion or else install cacti from source.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page