The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing CPanel, can not get to 2087

Discussion in 'General Discussion' started by techpartners, Apr 5, 2005.

  1. techpartners

    techpartners Registered

    Joined:
    Apr 5, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Just installed CPanel, and I am on the step of going to the 2087 port to finish install and get certificate.

    At the moment for testing I do not have a firewall running, so this is not the problem.

    On the first install of Redhat I installed XWindows, then to find out that CPanel disables it for security reasons. The reason for this was to have a browser to go to the page on the server.

    Reformated and reinstalled RedHat9, then CPanel.

    I tried to get to the https://xxx.xxx.xxx.xxx:2087 from a remote machine, but gets page can not be displayed. Are you able to get to this page from a remote computer?

    If you can not do it from a remote then will this work with a text based browser. If so, can someone recomend one, where they got it, and the install procedure.

    If you are supposed to be able to even access this page from a remote browser then what else could be the problem?

    Thanks for any help. Just need to get this last step done.
     
  2. techpartners

    techpartners Registered

    Joined:
    Apr 5, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ok using links

    Just posted message before this one.

    I got links and installed on the local machine, when I try to go to https://xxx.xxx.xxx.xxx:2087 on the machine with the same IP with an SSH connection. I get a connection refused.

    I am not running a firewall at this time, unless Redhat 9 installs one by default.


    Any further suggestions?
     
  3. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Does http://...:2086 work?

    Did you generate a self-signed cert for WHM and CPANEL to use? You need to do that before secure transactions through 2087 will work. You can do this in WHM itself by accessing it first without SSL, generating the cert and then 2087 should work.
     
  4. techpartners

    techpartners Registered

    Joined:
    Apr 5, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    2086 does not work either

    Tried http://xxx.xxx.xxx.xxx:2086 within links on a ssh connection into the machine and get same connection refused. I was tyring the 2087 per CPanel's instructions on their web site.

    How else can you generate a certificate if not using 2086 or 2087 for the setup?

    Thanks in advance.
     
  5. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    WHM may not be running.

    Did you try logging into your server as root via SSH and typing:

    service cpanel restart

    and then trying WHM again?
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can also check whether it's got the ports bound with:

    netstat -lpn

    If it has, then you might have a restrictive firewall installed (they're sometimes installed during the initial OS install if you're not careful) and then the following would probably help (if you running Linux):

    /etc/init.d/iptables stop
     
  7. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    I am going mad with this problem....even though I have reset and recreate / install the certificate I cannot access the 2087 and https.

    I did all the above and also read a couple of similar threads but without sucess.
    Any help is much appretiate.
     
  8. abubin

    abubin Well-Known Member

    Joined:
    Dec 7, 2004
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    did you turn off any firewall that might be causing this?

    chirpy's suggestion to turn off iptables should have switched off your firewall. Can your server access other internet sites?
     
  9. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Are you able to access it with the normal port.. I mean with 2086

    Then assuming you have stopped the firewall, did you check if https is really working on the server.

    Are you able to start apache with this command

    /usr/local/apache/bin/apachectl startssl
     
  10. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    2086 port is working fine.
    Apache is running in ssl mode and I cannot figure what's going on.
    Firewall is not enabled, it is a vps without any iptables script at all.

    SSL, 443 port is working fine in the server. I did a telnet localhost 443 and I am getting a responce.

    When I wrote http://mydomain.com:443 is working but with https is not working. I've seen this problem somewhere else in the past but I cannot remember how I solve it....

    Any help is much appretiate.

    Thanks
     
    #10 asmar, Aug 4, 2005
    Last edited: Aug 4, 2005
  11. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16
  12. OCX

    OCX Well-Known Member

    Joined:
    Sep 20, 2003
    Messages:
    232
    Likes Received:
    0
    Trophy Points:
    16

    lol ok so im a bit slow, that was gonna be my next option to tell you ironic
     
  13. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    ok I sort it out!

    I did:
    /etc/init.d/xinetd stop
    /etc/init.d/cpanel restart and done!
     
  14. asmar

    asmar Well-Known Member

    Joined:
    Jul 16, 2004
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    A bad update to this post.... I submit a while ago a ticket regarding this issue to cpanel support and they fix it temporary.
    After a few days same problem happened again.
    Almost 3-4 times per day this problem is coming up even though I format and reinstall cpanel in a clean server.

    I am getting always a connection refused and cpanel and whm is not working at all.

    I am getting a Page does not contain any data.

    I've searched everywhere in the forum and tried almost everything without success.

    Any help is much appretiate.
     
  15. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    run as root on shell:

    /usr/local/cpanel/startstunnel
     
  16. Adrnalnrsh

    Adrnalnrsh Well-Known Member

    Joined:
    Apr 6, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    AZ
    #16 Adrnalnrsh, Apr 29, 2006
    Last edited: Apr 29, 2006
  17. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    This may help if you're on release or stable:

    cd /usr/local/cpanel/src/3rdparty/perl/Net_SSLeay.pm-1.25
    perl Makefile.PL
    make
    make install
    /etc/init.d/cpanel restart


    Otherwise, you'll have to log it with cPanel through your license provider.
     
  18. Solokron

    Solokron Well-Known Member

    Joined:
    Aug 8, 2003
    Messages:
    849
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Seattle
    cPanel Access Level:
    DataCenter Provider
    This worked for me:

    apf -f
    iptables --flush

    Forced reinstall of stunnel via WHM @ Port 2086

    /scripts/upcp --force

    /etc/rc.d/init.d/cpanel restart
     
Loading...

Share This Page