Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Installing FFmpeg - on the Perl scripts

Discussion in 'General Discussion' started by selbach, Feb 20, 2006.

  1. selbach

    selbach Member

    Joined:
    Jan 5, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    I need the FFmpeg and is trying to install it with the script/perl installer but get the following faults

    Attempting to install FFmpeg

    spawn /scripts/perlinstaller FFmpeg
    Method: Perl Expect
    Testing connection speed...(this could take a while)....Done

    Three usable mirrors located

    Mirror Check passed for mirror.uni-c.dk (/index.html)

    Dropping unknown config variable 'less'

    Dropping unknown config variable 'make_test'

    commit: wrote '/usr/lib/perl5/5.8.7/CPAN/Config.pm'

    CPAN: Storable loaded ok

    Going to read /home/.cpan/Metadata

    Database was generated on Sun, 19 Feb 2006 02:19:07 GMT

    Running install for module FFmpeg

    Running make for A/AL/ALLENDAY/FFmpeg-0.03.tar.gz

    CPAN: Digest::SHA loaded ok

    CPAN: Module::Signature loaded ok

    WARNING: This key is not certified with a trusted signature!

    Primary key fingerprint: 2E66 557A B97C 19C7 91AF 8E20 328D A867 450F 89EC

    Signature for /home/.cpan/sources/authors/id/A/AL/ALLENDAY/CHECKSUMS ok

    CPAN: Compress::Zlib loaded ok

    Checksum for /home/.cpan/sources/authors/id/A/AL/ALLENDAY/FFmpeg-0.03.tar.gz ok

    Scanning cache /home/.cpan/build for sizes

    Deleting from cache: /home/.cpan/build/FFmpeg-0.03 (10.7>10.0 MB)

    FFmpeg-0.03/

    FFmpeg-0.03/t/

    FFmpeg-0.03/t/05.mp2.t

    FFmpeg-0.03/t/01.FFmpeg.t

    FFmpeg-0.03/t/06.mp3.t

    FFmpeg-0.03/t/09.http.t

    FFmpeg-0.03/t/04.mov.t

    FFmpeg-0.03/t/07.m2v.t

    FFmpeg-0.03/t/02.asf.t

    FFmpeg-0.03/t/10.perf.t

    FFmpeg-0.03/t/08.capture.t

    FFmpeg-0.03/t/03.avi.t

    FFmpeg-0.03/eg/

    FFmpeg-0.03/eg/t1.asf

    FFmpeg-0.03/eg/t1.mov

    FFmpeg-0.03/eg/t1.mpg

    FFmpeg-0.03/eg/t1.mp2

    FFmpeg-0.03/eg/t1.avi

    FFmpeg-0.03/eg/t3.asf

    FFmpeg-0.03/eg/t2.asf

    FFmpeg-0.03/eg/t1.mp3

    FFmpeg-0.03/eg/t2.avi

    FFmpeg-0.03/eg/t2.mov

    FFmpeg-0.03/eg/t1.m2v

    FFmpeg-0.03/Changes

    FFmpeg-0.03/FFmpeg/

    FFmpeg-0.03/FFmpeg/StreamGroup.pm

    FFmpeg-0.03/FFmpeg/Stream/

    FFmpeg-0.03/FFmpeg/Stream/Video.pm

    FFmpeg-0.03/FFmpeg/Stream/Unknown.pm

    FFmpeg-0.03/FFmpeg/Stream/Data.pm

    FFmpeg-0.03/FFmpeg/Stream/Audio.pm

    FFmpeg-0.03/FFmpeg/FileFormat.pm

    FFmpeg-0.03/FFmpeg/Stream.pm

    FFmpeg-0.03/FFmpeg/ImageFormat.pm

    FFmpeg-0.03/FFmpeg/Codec.pm

    FFmpeg-0.03/MANIFEST

    FFmpeg-0.03/META.yml

    FFmpeg-0.03/FFmpeg.xs

    FFmpeg-0.03/fonts.dir

    FFmpeg-0.03/FFmpeg.pm

    FFmpeg-0.03/FFmpeg.c

    FFmpeg-0.03/Makefile.PL

    FFmpeg-0.03/README

    Package came without SIGNATURE





    CPAN.pm: Going to build A/AL/ALLENDAY/FFmpeg-0.03.tar.gz



    you didn't define environmental variable $FFMPEG_ROOT at Makefile.PL line 6.

    CPAN: YAML loaded ok

    make: *** No targets specified and no makefile found. Stop.

    /usr/bin/make -- NOT OK

    Running make install

    make had returned bad status, install seems impossible

    perlmod--Install done
     
  2. visiox

    visiox Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    Howdy,

    the answer is in your posting ;-)

    try a export FFMPEG_ROOT='/wherever_ffmpef_is'
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. selbach

    selbach Member

    Joined:
    Jan 5, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    You are right - but where is this make file ??? ...
     
  4. visiox

    visiox Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    It doesn't matter where the Makefile.PL is ;)

    Find out where your ffmpeg binary is, let's say "/usr/local/bin"

    ok...

    now type on the command line

    export FFMPEG_ROOT='/usr/local/bin'
    perl -MCPAN -e 'install FFmpeg'

    that's it... :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. selbach

    selbach Member

    Joined:
    Jan 5, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    :confused:

    But I am using the cpanel to import it with - which takes it from a other server defined by the Cpanel team ... in the the menu "Main >> Software >> Install a Perl Module"


    But how do one then do it through a ssh channel ... where one give it an order to get it from a other server - hope to hear from you soon :D
     
  6. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    166
    I am getting the same error. Plus that the ffmpeg 0.03 is old and that there is 0.049
     
  7. visiox

    visiox Well-Known Member

    Joined:
    Jan 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    156
    Hi there,

    yep, I'm also getting the error.
    That's why I would use SSH...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,700
    Likes Received:
    72
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    from ssh
    perl -MCPAN -e shell

    at the prompt
    install FFmpeg


    but if cpanel is failing to install cpan will most likly fail as well


    install from soruce from http://cpan.org

    wget http://search.cpan.org/CPAN/authors/id/A/AL/ALLENDAY/FFmpeg-0.03.tar.gz
    tar -xzvf FFmpeg-0.03.tar.gz
    cd FFmpeg*

    This module requires these other modules and libraries:
    depenencies
    Image::Magick ?.??
    Image::Magick::Iterator 0.01
    Image::PBMlib 1.05
    Time::Piece, 1.08

    # set $FFMPEG_ROOT environmental variable to /path/to/ffmpeg/source
    perl Makefile.PL
    make
    make test
    make install
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. dob3rman

    dob3rman Active Member

    Joined:
    Feb 13, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    I am still not able to install FFmpeg on my server!!

    I noticed some magick errors wich might mean that i need magick to be installed?

    How to do so? I am a bit new when it comes to install from the console.


    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,700
    Likes Received:
    72
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    hence the depenancies list "Image::Magick"
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. dob3rman

    dob3rman Active Member

    Joined:
    Feb 13, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    Ok now i tried installing Magick using the /scripts/installimagemagick

    This is what i get ?

    Magick.xs:223: error: 'MagickInterpolateOptions' undeclared here (not in a function)
    Magick.xs: In function 'SetAttribute':
    Magick.xs:1386: error: void value not ignored as it ought to be
    Magick.xs:1386: warning: statement with no effect
    Magick.xs:1594: error: void value not ignored as it ought to be
    Magick.xs:1594: warning: statement with no effect
    Magick.xs:1793: error: 'struct _ImageInfo' has no member named 'transparent_color'
    Magick.xs:1793: warning: statement with no effect
    Magick.xs:1795: error: 'struct _Image' has no member named 'transparent_color'
    Magick.xs:1795: warning: statement with no effect
    Magick.xs:1904: error: 'struct _ImageInfo' has no member named 'virtual_pixel_method'
    Magick.xs:1904: warning: statement with no effect
    Magick.c: In function 'XS_Image__Magick_Animate':
    Magick.c:2093: warning: unused variable 'ref'.....

    Any help would be appreciated!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. dob3rman

    dob3rman Active Member

    Joined:
    Feb 13, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    /For my previous post --> /scripts/fixheaders did the job!!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. SACHIN

    SACHIN Guest

    Magick.xs:10434: warning: statement with no effect

    HI.



    I am still getting same error. i tried following all things.


    Magick.xs:10434: warning: statement with no effect

    1)upcp
    2)download latest tar ball form website and trying to install but same error
    i tried to install from cpanel same error

    i am unable to install it i am always get above error for image magick

    i run /scripts/fixheaders too but no luck.




    :confused:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice