Installing mod-pagespeed and dependencies

maestroc

Well-Known Member
Aug 23, 2012
59
0
6
cPanel Access Level
Reseller Owner
I'm a fairly new webmaster and am sure there is a simple solution to this so if anyone can help me thank you!

I am trying to install mod-pagespeed from Google on a CentOS/cpanel server. I have the file downloaded and tried to install it but get

Code:
error: Failed dependencies:
        httpd >= 2.2 is needed by mod-pagespeed-stable-1.4.26.3-3101.i386
during the install but according to WHM and EasyApache I already have httpd 2.2.24 installed.

I would really like to get this working locally as when I used the PageSpeed Service (changing CNAME records to use Google as a proxy and let their server run the optimizations) it nearly doubled the load speeds of all of the pages on my site. The problem is that I kept having cache problems and other issues that made me finally switch the CNAME back to normal.

Anyone know how I can get pagespeed to install properly?