Chris H

Member
May 5, 2017
7
3
3
London
cPanel Access Level
DataCenter Provider
Hi,

We really need mod_perl on one of our cPanel servers for a legacy website that unfortunately uses it. I know this was originally in EA3, but was removed in EA4?

What is the situation with EA4? If I just yum install mod_perl will I live to tell the tale? :) (the only site on this server will be this one site - so not bothered about mod_perl causing shared user security issues)

Thanks!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hi Chris,

There's currently no support for Mod_Perl in EasyApache 4. It wasn't included with EasyApache 4 because up until recently it was not supported with Apache version 2.4. You'd need to build it as a custom package using the instructions on the following page:

ea4.ninja

Or, consider opening a feature request for it's inclusion with EA4 at:

Submit A Feature Request

Thank you.