Installing new cPanel instance from Backup Image!??

peconi

Active Member
Mar 27, 2005
28
0
151
Hi guys,

I am on SliceHost.com and they offer a very nice backup utility which takes a snapshot of my whole VPS machine.

I installed manually an instance of cPanel, configured the whole "server", PHP, etc. and then made a snapshot of that installation.

I'd like to create couple of new VPS machines FROM this snapshot.

When I did it - I went to the Basic Setup - made sure the IP was set to the new VPS server IP, went to HostName and changed it from slice1.mydomain.com to slice2.mydomain.com.

EVERYTHING seems to work PEFECTLY FINE - EXCEPT ONE THING:

When I try to go to the cPanel on the domain names ON THE NEW Installation, say mydomain2.com/cpanel --- it redirrects me to slice1.mydomain.com instead of using the slice2 (the current machine's hostname).

If I go to cpanel.mydomain2.com it works fine, but it somehow seems that somewhere in the settings, the first installations host name stayed in.

I checked resolv.conf, named.conf, httpd.conf, and everywhere in WHM settings (under hostname, tweaks, etc.) - everything points to the Second hostname (as it should), however, going to a domain/cpanel redirrects me to the first server for some reason.

Does anyone know where is this hiding?
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,212
13
313
Houston, TX
cPanel Access Level
Root Administrator
Offhand, one thing I can think of - are you using SSL certificates for cPanel/WHM/Webmail? If you are redirecting to the SSL certificate name and have an old certificate reflecting that former server, that could be the cause of the issues.