Installing new SSL certificate

PatrickVeenstra

Well-Known Member
Feb 12, 2012
158
3
68
Barcelona
cPanel Access Level
Root Administrator
After buying (and installing) a new SSL certificate because the old one expired, I'm still getting the expired warning.

BTW I installed the certificate by copy-pasting it into the text box, but using the "install" button returns:
Template::Exception:
[TYPE]=[undef]
[INFO]=[SSL::installed_hosts() failed: You do not have the feature “sslinstall”.
]
[TEXT]=[]
at cpanel.pl line 1031.
cpanel::cpanel::cptt_exectag("/usr/local/cpanel/base/frontend/paper_lantern/ssl/install.htm"..., 1) called at cpanel.pl line 4383
cpanel::cpanel::run_standard_mode() called at cpanel.pl line 845
cpanel::cpanel::script("cpanel::cpanel", "./frontend/paper_lantern/ssl/install.html.tt") called at cpanel.pl line 267

edit: I've "upgraded" the account to the default feature set to make sure "SSL Host Installer" is active.

p.s. Is it a bug that when you remove a certificate is CPanel it still shows up in WHM? -I've removed it from WHM also, and now it's gone.
 
Last edited:

PatrickVeenstra

Well-Known Member
Feb 12, 2012
158
3
68
Barcelona
cPanel Access Level
Root Administrator
Also in WHM:
Home »SSL/TLS »Purchase and Install an SSL Certificate
Click on the account's: "Goto CPanel" and you get "This feature is not available to your account."

It seems that somehow the ticket didn't get opened correctly. So I've created a new ticket: #11412861
 

cPanelLauren

Forums Analyst II
Staff member
Nov 14, 2017
8,012
648
263
Houston
cPanel Access Level
DataCenter Provider
Hi @PatrickVeenstra

I just checked in on that ticket and it would appear this was due to the Tweak Setting option "Allow cPanel users to install SSL Hosts." being disabled, as well as internal case CPANEL-24656 which has been corrected in cPanel / WHM 78 and is reflected in our changelog here:
78 Change Log - Change Logs - cPanel Documentation

To resolve the issue for you presently our analyst enabled the tweak setting and then rebuilt the cache allowing for the setting to actually reflect as being enabled.
 

PatrickVeenstra

Well-Known Member
Feb 12, 2012
158
3
68
Barcelona
cPanel Access Level
Root Administrator
The setting was enabled (at least on the other account), but CPanel didn't rebuild the cache.

In case anyone else has this issue, you can rebuild the cache manually from the command line: /usr/local/cpanel/bin/build_global_cache