SOLVED Installing Perl Module DBD::ODBC


Aug 29, 2016
Gold Coast
cPanel Access Level
Root Administrator
Can anyone who has installed the perl module DBD:ODBC on a centos cpanel server supply a step by step?

Looks like an ODBC 'Driver Manager' needs to be installed first.
So I take it I'll need to install unixodbc package.
Then indicate where it is installed by setting the ODBCHOME variable.

Is that right?

Output from cpan when attempting to install:
You are using a Perl configured with threading enabled.
Please read the warnings in DBI about this.

You should also be aware that on non-Windows platforms ODBC drivers come
in two forms, thread-safe and non-thread-safe drivers and you may need
to make sure you are using the right one.

Press return to continue... 
Looking for odbc_config in : nowhere
Looking for odbc_config in (PATH) /usr/local/jdk/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
  odbc_config not found
Looking for iodbc-config in PATH /usr/local/jdk/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
  iodbc_config not found
odbc_config not found - ok, there are other things I can do
Still trying to guess ODBCHOME - looking for headers now
  trying /usr/include
  trying /usr/local/include
  trying /usr/pkg/include
  trying /usr/local/easysoft/unixODBC/include

I cannot find driver manager header files. Perhaps you need to install the
unixodbc-dev package or the iodbc-dev package

The DBD::ODBC module needs to link with an ODBC 'Driver Manager'.
(The Driver Manager, in turn, needs one or more database specific ODBC
drivers. The DBD::ODBC module does _not_ include any ODBC drivers!)

You need to indicate where your ODBC Driver Manager is installed.
You can do this by:

o setting the ODBCHOME environment variable
o running 'perl Makefile.PL -o odbcdir'
o adding path to odbc_config/iodbc_config to PATH

If you do not have an ODBC Driver Manager you should try to get hold of
the unixODBC packages for your system or build it from source (see
unixODBC). If you install driver manager packages you
need to include the "XXX-dev" package which includes the C header files.
No 'Makefile' created  MJEVANS/DBD-ODBC-1.56.tar.gz
  /usr/bin/perl Makefile.PL -- NOT OK
Failed during this command:
 MJEVANS/DBD-ODBC-1.56.tar.gz                 : writemakefile NO -- No 'Makefile' created
Last edited by a moderator:


Staff member
Apr 11, 2011