The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing PHP 5.2

Discussion in 'General Discussion' started by johnhms, Nov 14, 2012.

  1. johnhms

    johnhms Registered

    Joined:
    Nov 14, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    I understand the latest WHM installs PHP interpreters in /usr/local/cpanel/3rdparty/bin/php, /usr/bin/php, /usr/local/bin/php, /var/cpanel/3rdparty/bin/php, as indicated here: Improving the Internal PHP | cPanel, Inc.. This is how it is for me as I'm currently running php 5.3.18 after my latest install of WHM.

    However, I'm in a situation where I have to install PHP 5.2 (it's a zend optimizer issue).

    So my question is:

    1) Can I freely install a new single installation of php 5.2 on my box?
    2) If so, how do I make it so that virtual host X can use php 5.2?

    Any help would be appreciated, thank you.
     
  2. johnhms

    johnhms Registered

    Joined:
    Nov 14, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Basically in a nuthsell, my WHM has 5.3.18 installed, how do I have it work with php 5.2.x?
     
  3. johnhms

    johnhms Registered

    Joined:
    Nov 14, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Sorry, I just installed php5.2 (deprecated) via EasyApache. That really was easy.
     
Loading...

Share This Page