aseptik

Member
Jan 23, 2018
8
0
1
Italy
cPanel Access Level
Root Administrator
Hi all,

i'm little confused on how to install ImageMagick for PHP.

i'm running a server with:

  • CENTOS 7.5
  • cpanel v74.0.9
  • ImageMagick is not installed on the server
  • Under “PHP Pecl” Installer i see "imagick (3.4.3)" not installed
  • PHP Version 7.0.32
Since the server is live and running i don't want to mess up things (i would like to avoid problems like version inconpatibility, etc...).

So, i'm wondering if there is a, proven, step by step process to install the PHP extension ?

thank you as always for the support!
 
Last edited by a moderator:

linux4me2

Well-Known Member
Aug 21, 2015
259
78
78
USA
cPanel Access Level
Root Administrator
I went through this a while back. There were a couple of issues I ran into that might help.

When I tried to run the module installer to install Imagick, I got an error that popen() was disabled, and had to temporarily remove it from my disabled functions list in the php.ini for the relevant version of PHP to get Imagick installed, then add it back after the installation.

After I got Imagick installed, it still showed it wasn't enabled when I looked at phpinfo(). I restarted Apache, and still, no joy. I finally realized that since I was running PHP-FPM, I had to restart the PHP-FPM service to get Imagick enabled.

Once I restarted PHP-FPM, it worked like a charm.
 

thenocgroup

Registered
Jun 25, 2018
4
0
1
argentina
cPanel Access Level
Root Administrator
Hi Guys!
I have the same problem, I installed this one (Apache::ImageMagick (2.0b7)) , I already reboot the server a couple of times but when I run a plugin in my website I keep viewing the same error: "No php extensions are available to edit images on the server. "

  • CENTOS 7.6
  • cpanel v76.0.14
  • ImageMagick is not installed on the server
  • PHP Version 7.0.3
Any idea?
Thank you so much!!
 

linux4me2

Well-Known Member
Aug 21, 2015
259
78
78
USA
cPanel Access Level
Root Administrator
It seems like rebooting the server should have done it, but if you're using PHP-FPM, you might try restarting it specifically: WHM > Restart Services > PHP-FPM Service for Apache.
 

Metro2

Well-Known Member
May 24, 2006
530
76
178
USA
cPanel Access Level
Root Administrator
I went through this a while back. There were a couple of issues I ran into that might help.

When I tried to run the module installer to install Imagick, I got an error that popen() was disabled, and had to temporarily remove it from my disabled functions list in the php.ini for the relevant version of PHP to get Imagick installed, then add it back after the installation.

After I got Imagick installed, it still showed it wasn't enabled when I looked at phpinfo(). I restarted Apache, and still, no joy. I finally realized that since I was running PHP-FPM, I had to restart the PHP-FPM service to get Imagick enabled.

Once I restarted PHP-FPM, it worked like a charm.
This was a big help / reminder for me today. I haven't had to do it in a while, but just recently added PHP 7.4 since Ioncube 10.4 now supported EA / CloudLinux, and of course first thing I tested was a WP Site Health check, and sure enough it warned "the optional module, imagick, is not installed". So I used the Module installer in WHM and ran into the popen() issue, quickly did the php.ini edits to enable / install / disable, but completely forgot about the necessary PHP-FPM restart.

This place is such a huge help!
 

spadilha

Registered
Dec 27, 2020
2
2
3
Brazil
cPanel Access Level
Root Administrator
After I got Imagick installed, it still showed it wasn't enabled when I looked at phpinfo(). I restarted Apache, and still, no joy. I finally realized that since I was running PHP-FPM, I had to restart the PHP-FPM service to get Imagick enabled.

Once I restarted PHP-FPM, it worked like a charm.
Thanks Dude! I've spent hours looking for this.
 
  • Like
Reactions: cPRex