installing php pecl "imagick"

Cemtey

Well-Known Member
Aug 19, 2007
69
0
56
Installing PHP Pecl "imagick"

pecl/imagick requires PHP (version >= 5.1.3), installed version is 4.4.7
No valid packages found
install failed
The imagick.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20020429
That means I should update php version and try again?
While updating php version how much could go wrong? I've tried that before but for CURL I decided to stick with older version of php. Pros and cons of older version and would CURL work when I update to new version of php or would that be problem?
 
Last edited:

rhenderson

Well-Known Member
Apr 21, 2005
785
1
166
Oklahoma
cPanel Access Level
Root Administrator
Guess that depends on what older scripts are running on your server, we changed over to PHP ver 5 about 18 months ago, ran PHP 4 and 5 side-by-side before it was an option in WHM. That way if there was an older version we could just pop in an .htaccess file and have it run version 4. You could run them both since it is an option in easy apache. When we added the imagemagick module we had to compile it by hand pecl would not work for us. BTW curl is working fine with PHP 5.2.6

Just be ready to fix anything that breaks, good luck.