The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing SSL Cert....what am I doing wrong?

Discussion in 'General Discussion' started by skeedo, Jul 25, 2013.

  1. skeedo

    skeedo Registered

    Dec 30, 2002
    Likes Received:
    Trophy Points:
    I wish I could figure out why I'm having so much trouble installing SSL certs in WHM. 75% of the time, it won't populate the domain, username and IP fields after I paste the cert.

    I'm told it has a lot to do with whitespace, however I have tried everything possible to eliminate all whitespace. Copied and pasted the cert from varioius text editors, editted the cert to eliminate all extra whitespace both in the editor before copying and also after pasting in the certificate box. It just doesn't want to work for me the majority of the time.

    I'm sure there's something I must be doing wrong because I'm not able to find threads regarding this issue. Help?
    #1 skeedo, Jul 25, 2013
    Last edited: Jul 25, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you let us know which version of cPanel is installed on your system? You can check via:

    cat /usr/local/cpanel/version
    Are you generating the CSR/Key before purchasing the CRT file and attempting to install it?

    Thank you.

Share This Page