The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing Subversion with cPanel

Discussion in 'General Discussion' started by viptexting, Feb 19, 2008.

  1. viptexting

    viptexting Well-Known Member

    Joined:
    Sep 19, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    I want to install subversion on my testing server to host a few repos I currently store locally, just in case something happens I'll then have a remote backup (and a NAS backup of the backup!).

    I've looked on google and there are a few guides, but they seam to be geared towards cPanel <11 as they mention no Apache 2 support with cPanel (which is obviously not the case for about 6 months now).

    What I am thinking of doing is as follows:

    1. Rebuild Apache, including the required DAV modules.
    2. Compile the mod_svn module.
    3. Modify the httpd.conf to work with SVN.
    4. Run the config distiller to save my modified httpd.conf.

    I'm wondering if anyone has tried this, if it works ok etc without having to have a separate Apache install and using mod_proxy to access the SVN.
     
  2. viptexting

    viptexting Well-Known Member

    Joined:
    Sep 19, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Well I gave it a go, so far so good...

    I initially removed the subversion which was already installed with CentOS, and compiled/installed subversion 1.4.6 however this broke the client, so I reinstalled the CentOS package and built/installed 1.4.2 just to be safe and avoid further issues.

    I added the LoadModule lines to the 2.2.8 pre main file from WHM, restarted Apache, all seems well - DAV/2 SVN/1.4.2 is now listed in the server sig. :)
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Make sure you wrap any subversions directives in

    <IfModule> statements


    I'd imagine you'd want <IfModule mod_dav_svn.c> to be exact.
     
  4. kiranchand

    kiranchand Registered

    Joined:
    Sep 16, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    kerala
  5. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    Get the correct subversion version

    I've been wrestling with this all day on a CentOS 5.1 system, but getting strange db_create errors when trying to load

    Code:
    LoadModule dav_svn_module /usr/lib64/httpd/modules/mod_dav_svn.so
    into the apache include editor. Couldn't find any good solutions here or in Google. Seemed to be related to DB4 (Berkeley DB) compatibility, but couldn't figure out how or what. Finally hit on the solution and thought I'd share.

    Turns out the versions of subversion and mod_dav_svn that are available through the official CentOS yum repos are compiled against BerkeleyDB, but that doesn't work. Fortunately svn can fall back on other storage systems. To fix:

    1) Remove subversion and mod_dav_svn via yum:

    Code:
    yum erase subversion
    yum erase mod_dav_svn
    2) Go to http://subversion.tigris.org/ and from there to binary RPM downloads section. You'll see this notice:

    Aha! Exactly what you need. Navigate to the downloads for your OS and CPU (in my case this).

    Download rpms for subversion and mod_dav_svn to /usr/local/src or somewhere, then install them with yum, bypassing the repos, e.g.:

    Code:
    yum localinstall ./subversion-1.4.6-1.rhel5.x86_64.rpm 
    yum localinstall ./mod_dav_svn-1.4.6-1.rhel5.x86_64.rpm 
    Now you should be able to load the module into the apache editor:

    Code:
    LoadModule dav_svn_module /usr/lib64/httpd/modules/mod_dav_svn.so
    Worked for me anyway.
     
  6. shacker23

    shacker23 Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    263
    Likes Received:
    1
    Trophy Points:
    16
    One more note: If yum complains that the package is not signed and then exits silently, edit /etc/yum.conf and set:

    gpgcheck=1

    to

    gpgcheck=0

    Then try again. Remember to restore the setting when you're done for security.
     
  7. blargman

    blargman Well-Known Member

    Joined:
    Sep 11, 2007
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    grab the latest subversion source

    ./configure --with-apxs=/usr/local/apache/bin/apxs --with-apr=/usr/local/apache --with-apr-util=/home/cpeasyapache/src/httpd-2.2.8/srclib/apr-util

    make
    make install

    replace 2.2.8 with whatever current httpd source your using.
    works for me, used it on several machines.
     
  8. djspark

    djspark Active Member

    Joined:
    Feb 3, 2003
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much, this was driving me nuts! Now I've got it working :-D
     
Loading...

Share This Page