The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Installing thttpd on cPanel

Discussion in 'General Discussion' started by bofunk, Oct 20, 2005.

  1. bofunk

    bofunk Registered

    Mar 15, 2005
    Likes Received:
    Trophy Points:
    I'm trying to install thttpd on a server with cpanel and apache. I have thttpd installed and am trying to run it it on a separate IP. In order to gain access to that IP I had to set listen lines in the apache httpd.conf so that apache doesn't bind to all ips. If I restart apache manually through /usr/local/apache/bin/apachectl restart, the apache server starts to run. However, after 5 minutes or so it dies...if I try and start apache with WHM it won't start period...after I manually start it and it dies I checked the error_log this is what I get is:

    [Wed Oct 19 14:06:41 2005] [crit] (98)Address already in use: make_sock: could not bind to address port 80

    I've noticed if I start the server manually and do a ps -aux | grep httpd, the processes come up like this /usr/local/apache/bin/httpd, when WHM starts it (without the updated listen lines before I touch anything) it comes up like this /usr/local/apache/bin/httpd -DSSL ... im assuming its starting it with SSL support and I'm not? I tried /usr/local/apache/bin/httpd startssl and the server wouldn't start. It said it started but it doesn't. I really don't know if this is relevant or not, but I'm trying to supply as much information as possible.

    To sum it up, it seems as though either WHM is running a crontab to check for something running that isn't running when I manually start apache... or there is a flag I'm not starting it with that cpanel uses when it starts it... etc.... and unfortunately I can't see the commands that cpanel uses to start apache.

    If anyone has any ideas or has ever successfully installed another httpd and can throw some advice I'd greatly appreciate it.


    William Edmunds

Share This Page