avante2500

Registered
May 2, 2019
1
0
1
australia
cPanel Access Level
Website Owner
Hi,
Im trying to install tomcat server in whm centos 6, the problem is asking me to install GCJ then when i try yum install java-gcj-compat . Says no package available ! any idea ?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Which tomcat package are you trying to install? The CentOS provided package or cPanel's?

cPanel's tomcat package is:
Code:
ea-tomcat85.x86_64
It installs the following dependencies (on my server at least:

Code:
Dependency Installed:
  apache-commons-daemon.x86_64 0:1.0.13-7.el7                           apache-commons-daemon-jsvc.x86_64 0:1.0.13-7.el7               apache-commons-lang.noarch 0:2.6-15.el7
  apache-commons-logging.noarch 0:1.1.2-7.el7                           atk.x86_64 0:2.28.1-1.el7                                      avalon-framework.noarch 0:4.3-10.el7
  avalon-logkit.noarch 0:2.1-14.el7                                     cal10n.noarch 0:0.7.7-4.el7                                    ea-apache24-mod_proxy_ajp.x86_64 0:2.4.39-2.2.1.cpanel
  geronimo-jms.noarch 0:1.1.1-19.el7                                    geronimo-jta.noarch 0:1.1.1-17.el7                             gtk-update-icon-cache.x86_64 0:3.22.30-3.el7
  gtk2.x86_64 0:2.24.31-1.el7                                           hicolor-icon-theme.noarch 0:0.12-7.el7                         java-1.8.0-openjdk.x86_64 1:1.8.0.212.b04-0.el7_6
  java-1.8.0-openjdk-devel.x86_64 1:1.8.0.212.b04-0.el7_6               javamail.noarch 0:1.4.6-8.el7                                  javassist.noarch 0:3.16.1-10.el7
  libXcomposite.x86_64 0:0.4.4-4.1.el7                                  libXcursor.x86_64 0:1.1.15-1.el7                               libXi.x86_64 0:1.7.9-1.el7
  libXinerama.x86_64 0:1.1.3-2.1.el7                                    libXrandr.x86_64 0:1.5.1-2.el7                                 libXtst.x86_64 0:1.2.3-1.el7
  log4j.noarch 0:1.2.17-16.el7_4                                        mysql-connector-java.noarch 1:5.1.25-3.el7                     pcsc-lite-libs.x86_64 0:1.8.8-8.el7
  slf4j.noarch 0:1.7.4-4.el7_4                                          tomcat-servlet-3.0-api.noarch 0:7.0.76-9.el7_6                 ttmkfdir.x86_64 0:3.0.9-42.el7
  xalan-j2.noarch 0:2.7.1-23.el7                                        xerces-j2.noarch 0:2.11.0-17.el7_0                             xml-commons-apis.noarch 0:1.4.01-16.el7
  xml-commons-resolver.noarch 0:1.2-15.el7                              xorg-x11-fonts-Type1.noarch 0:7.5-9.el7

Dependency Updated:
  java-1.8.0-openjdk-headless.x86_64 1:1.8.0.212.b04-0.el7_6