The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Interactive Keyboard Authentication

Discussion in 'Security' started by pgolding, Jun 19, 2013.

  1. pgolding

    pgolding Member

    Joined:
    Feb 13, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,

    I have generated my keys and can access via Putty quite happily, I then disabled interactive keyboard authentication in WHM

    At my first test, the result was as expected, I got a message about keyboard authentication being disabled.

    Second attempt I could connect via keyboard authentication???


    I have tried from other networks (in case something was cached) same result.

    Any ideas please?

    Please note I am not an experienced user
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You mentioned modifying "Interactive Keyboard Authentication" from Web Host Manager. Are you referring to the "SSH Password Authorization Tweak"? If so, disabling password authentication will require you to use a SSH key instead of the root password when accessing SSH. Is SSH still allowing password authentication?

    Thank you.
     
  3. pgolding

    pgolding Member

    Joined:
    Feb 13, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,

    Yes I am referring to the SSH Password Authorization Tweak, yes SSH is still allowing password authentication. even though it is disabled in WHM

    One other thing, I created the keys with puttygen and imported the key and not within the WHM interface - don't knw if that makes a difference

    thanks
    Paul
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The key should still work if you imported it manually. Could you try disabling/enabling the "SSH Password Authorization Tweak" option again to see if that makes a difference? You should notice a change to the "PasswordAuthentication" line in the /etc/ssh/sshd_config file. You can check this with a command such as:

    Code:
    grep PasswordAuthentication /etc/ssh/sshd_config
    Thank you.
     
  5. pgolding

    pgolding Member

    Joined:
    Feb 13, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    In WHM password authentication is set to disabled and the config shows password authentication as disabled (see below) however I can still login (and did to get the output) using password authentication

    root@mail [~]# grep PasswordAuthentication /etc/ssh/sshd_config
    #PasswordAuthentication yes
    PasswordAuthentication no

    Thanks

    Paul
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I have not been able to reproduce this behavior so it appears isolated to your individual server or local machine. Are you sure you are connecting to the correct server via SSH? Are you using the IP address or the hostname to connect via SSH? Does restarting the SSH service result in any error messages?

    You are welcome to open a support ticket if the issue continues so we can take a closer look:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  7. pgolding

    pgolding Member

    Joined:
    Feb 13, 2012
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi,

    Got it sorted and should have tried it first, I bounced the box and everything is now hunky dory!

    Thanks you for your help

    Cheers
    Paul
     

Share This Page