The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Interchange and CPanel 6

Discussion in 'General Discussion' started by sparek-3, Feb 22, 2003.

  1. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,383
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It appears that our servers were upgraded to CPanel 6 through the automatic update last night. This is fine, but it appears that Interchange is not working properly with this new build (atleast thats all I can find that was changed). Below is the error message that one of my clients gets:

    Admin interface will not work properly.

    Please install needed Perl modules:



    Term::ReadLine::Perl not found. Gives you filename completion and command history in the makecat program. Not used otherwise.

    The easiest way to do this is to use the CPAN module and do:

    perl -MCPAN -e 'install Bundle::Interchange'

    I checked, and the Term::Readline::Perl module is installed. The Bundle::Interchange is installed as well. I ran /scripts/fixinterchange and I still get this message.

    On another server, Interchange keeps going down, staying up for no more than 10 minutes. I don't think we have any clients on that server that use Interchange, but we still get the error message every 10 minutes. I've ran the /scripts/upcp script on that server, to upgrade it to CPanel 6 release 80, it had been running release 73. Perhaps this will fix the problems on that server, but thought I would mention it as well.

    Any help with the first issue, would be greatly appreciated.
     
  2. Admin356

    Admin356 Active Member

    Joined:
    Feb 19, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    After upgrading on a few servers, I found that Interchange was disabled (It was enabled prior to upgrading).

    Going into tweak settings and selecting the correct version to run fixed it for us, hope it's the same for you.
    Don't forget the /scripts/fixinterchange etc etc -
     
  3. Jeff @ PLC

    Jeff @ PLC Registered

    Joined:
    Feb 22, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I'm an end user and reseller trying to help my HOST fix the same problem. Needless to say I'm pissed, my clients are pissed, and I'm sure my ISP is tired of me by now :)

    What in the world happened? What libraries did Cpanel update or download that caused such a major messup with any server running Interchange?

    For testing purposes I deleted and re-installed Interchange on three different servers... the only thing that all three had in common is a major Cpanel update. Well, it's safe to say that the new release of Cpanel and Interchange are not very compatible. A quick solution is appreciated!

    Thanks,

    Jeff @ PLC
     
  4. jonc

    jonc Registered

    Joined:
    Feb 23, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    What version of SQL::Statement is CPanel using now?

    Interchange requires that version 0.1021 is installed, and its not compatible with the latest version. Bundle::Interchange specifies the version earlier version.

    See http://www.icdevgroup.org/pipermail/interchange-users/2002-December/029939.html for more info. (note that this was discussed in december last year, <sigh>..)

    If you are having problems with Interchange, you should check the error.log file in a catalog. Look for:

    Can't locate object method "where" via package "SQL::Statement" at /usr/local/interchange/lib/Vend/Scan.pm line..

    This indicates the SQL::Statement version problem.

    Jonathan.
     
Loading...

Share This Page