Interchange Error After Upgrading Perl

Curious Too

Well-Known Member
Aug 31, 2001
428
1
318
cPanel Access Level
Root Administrator
After upgrading to perl 5.6.1 the following Interchange error is returned:

interchange: error in loading shared libraries: /usr/lib/perl5/site_perl/5.6.1/i686-linux/auto/Crypt/SSLeay/SSLeay.so: undefined symbol: OPENSSL_free

Crypt::SSLeay is the latest version. Any ideas?
 

DHL

Well-Known Member
Mar 8, 2002
88
0
306
How did you fix this, I have the same problem I think, after upgrading to perl 5.6.1 I don't get that exact error but get a lot of garble when installing Interchange and the admin interface is showing 500 internal server error. I ran the fix scripts but nothing changed - 500 error.

This is the output from cpanel when installing a cart:-

chgrp: too few arguments Try `chgrp --help' for more information. chgrp: too few arguments Try `chgrp --help' for more information. chgrp: too few arguments Try `chgrp --help' for more information. chgrp: too few arguments Try `chgrp --help' for more information. chgrp: too few arguments Try `chgrp --help' for more information

This is referring to group, any ideas?

Steve