instantdesign

Registered
Jul 1, 2004
3
0
151
CPANEL is being wierd on me, this has never happened before but now i get about 135+ e-mails a day from my cpanel. This is just one of the most recent:

interchange failed @ Thu Jul 1 16:49:22 2004. A restart was attempted automagicly.

It does that about every 10 mins, and has been happening for the past 10 days. In the server status in cpanel for interchange it says failed and is blinking red. Any reason why this has happened, and what can we do to fix it? Thanks
 

BenThomas

Well-Known Member
Feb 12, 2004
598
0
166
Houston, Texas USA
cPanel Access Level
Root Administrator
Try reinstalling interchange.

cd /usr/local/cpanel/3rdparty
mv interchange interchange_OLD
tar zxvf interchange5.tar.gz
cp interchange/interchange.cfg.dist interchange/interchange.cfg

Run this script:

/scripts/fixinterchange
/scripts/rebuildinterchangecfg

Then try to restart interchange:

/usr/local/cpanel/bin/startinterchange

Now it should print some startup messages to STDERR and you should see interchange in the process list:

ps ax | grep interchange

Hope that helps.
 

instantdesign

Registered
Jul 1, 2004
3
0
151
I followed those steps then when i go to start it back up it gives me this:

Interchange will not work with a thread-enabled pearl.
BEGIN--failed--compilation aborted at /usr/local/3rdparty/interchange/bin/interchange line 49.
 

cPanelKyle

Senior Technical Analyst
Staff member
Feb 10, 2003
61
3
233
cPanel Access Level
Root Administrator
Twitter
instantdesign said:
I followed those steps then when i go to start it back up it gives me this:

Interchange will not work with a thread-enabled pearl.
BEGIN--failed--compilation aborted at /usr/local/3rdparty/interchange/bin/interchange line 49.
Try to recompile Perl from http://layer1.cpanel.net then run /usr/local/cpanel/startup afterwards and see if you still get an error.
 

Pereguin

Registered
Jul 15, 2004
4
0
151
ThaMATRiX said:
How do I do that? Would it be possible for you to list all the commands like was above? Thanks.
check which perl version is on your server

perl -v

then download the version you want

wget http://layer1.cpanel.net/perl561installer.tar.gz

or

wget http://layer1.cpanel.net/perl581installer.tar.gz

or

wget http://layer1.cpanel.net/perl584installer.tar.gz

untar: (if 5.8.4)

tar xzvf perl584installer.tar.gz

cd to the unpacked directory:

cd perl584installer

use the install script

./install


you may also want to check your interchange.cfg and allow it to run under higher server loads

pico /usr/local/cpanel/3rdparty/interchange/interchange.cfg

find:

Variable TRAFFIC low

change to:

Variable TRAFFIC high

save and exit.

Hope this helps
 
Last edited:

ThaMATRiX

Well-Known Member
Feb 1, 2004
196
0
166
Chicago
Well thanks for that, and I'm sure the other user who needed this will be happy as well, since it worked fine... But... I then did the original instructions from this post, and restarted interchange, and now it shows this in ssh

Code:
[email protected] [/usr/local/cpanel/3rdparty]# The Interchange server was not running (/usr/local/cpanel/3rdparty/interchange/etc/interchange.pid).
Low traffic settings.
Calling UI......UI is loaded...
Interchange V5.0.0
Interchange server started in UNIX mode(s) (process id 17498)
and stops there, and in the WHM Service Stats, it still has a red flashing light next to interchange. Any ideas? Thanks so much.
 

webits

Well-Known Member
May 15, 2004
114
0
166
Thanks helped!!!

Thank you that helped me out a lot....