The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Interchange upgrade causes death

Discussion in 'General Discussion' started by creepa, Dec 4, 2001.

  1. creepa

    creepa Registered

    Joined:
    Dec 3, 2001
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    i downloaded the new 4.8.3 tarball. installed it and everything went fine. it created a interchange-4.8.3 folder which i did a cp interchange-4.8.3/* interchange to put all the new files in the right folder. well now it wont run and when i try to go to the stores i get the erorr saying the stores are down. please shed some light on this please. thanks alot guys.
     
  2. creepa

    creepa Registered

    Joined:
    Dec 3, 2001
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    ok now i just get 404 errors. i can reach the cart but when i click on customer or admin it gives me 404s
     
  3. feanor

    feanor Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    836
    Likes Received:
    0
    Trophy Points:
    16
    Why did you decide on that course of action? Knowing that might shed some light on the subject, perhaps there was an error occuring previously?

    I would make a backup of the current /usr/local/cpanel/3rdparty/interchange directory, and then wipe it out completely, then axe /usr/local/cpanel/cpanel (just the small program itself there)... then /scripts/upcp and force layer2 back in, including a fresh interchange.

    You can then inject the interchange config into the mix again. Keep in mind this procedure is about 60% effective- I would make SURE you have the required perl modules for interchange in there before you do ANYTHING. (/scripts/fixinterchange)

    Good luck.


    :D
     
Loading...

Share This Page