Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Interesting Problem [very important]

Discussion in 'General Discussion' started by neuromancer, Jun 19, 2005.

  1. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Firstly
    while i running /scripts/easyapache an error occurred and after that httpd service doesn't work. Please help me. The error is below.

    root@neuro [~]# service httpd start
    Syntax error on line 1083 of /usr/local/apache/conf/httpd.conf:
    Invalid command 'BytesLog', perhaps mis-spelled or defined by a module not included in the server configuration
    /etc/init.d/httpd start: httpd could not be started

    And then I delete 'BytesLog' in /usr/local/apache/conf/httpd.conf. httpd service is working but the sites which work before don't work. It gives "There is no website configured at this address." error. What can I do ?
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India

    login to your server through ssh, Edit httpd.conf file and add the following lines;



    Under the Add Module section add;

    AddModule mod_log_bytes.c



    Under the Load Module section add;

    LoadModule bytes_log_module libexec/mod_log_bytes.so



    Restart apache and let me know the result

    ------
    Aby :) .
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    I did.

    After that, it gives that.

    root@neuro [/home]# service httpd restart
    /etc/init.d/httpd restart: httpd not running, trying to start
    Syntax error on line 1128 of /usr/local/apache/conf/httpd.conf:
    Invalid command 'v', perhaps mis-spelled or defined by a module not included in the server configuration
    /etc/init.d/httpd restart: httpd could not be started

    and the websites don't work :(
    but at that time it gives "The page cannot be displayed" error.
     
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India

    I suggest recompiling apache once again

    ---
    Aby :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Ok Ok it works thanks.

    While I editing, I added invailed charachter by mistake :)

    Thank you.
     
  6. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    And I want to ask one more question. How can I install GD support ??
     
  7. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    India
    You can add that during recompilation of apache using

    /scripts/easyapache

    choose the option 6, you'll find option for adding gd support.

    --------
    Aby :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    After I did these things my problem solved but another problem occurred. When I entered my server ip in Internet Explorer a website which I hosted it opens. In normally an error page which lists that "There is no website configured at this address." must open. How can I do for that problem ?
     
    #8 neuromancer, Jun 19, 2005
    Last edited: Jun 19, 2005
  9. MMarko

    MMarko Well-Known Member

    Joined:
    Apr 18, 2005
    Messages:
    316
    Likes Received:
    0
    Trophy Points:
    166
    This is normal. You can change this page by altering index.html in your /apache/htdocs folder.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. neuromancer

    neuromancer Member

    Joined:
    Jun 17, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    151
    Ok but big problem is mrtg page isn't accessable :(
    my problem is that
     
  11. brentp

    brentp Well-Known Member

    Joined:
    Mar 11, 2004
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Ayr, North Queensland, Australia
    Alias /mrtg/ /usr/local/mrtg/

    add that to your httpd.conf, also modify the dir for what applies in your situation.

    Regards,
    Brent
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice