The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Intermittent problems with cPanel account authentication

Discussion in 'General Discussion' started by jedgtucker, Dec 1, 2011.

  1. jedgtucker

    jedgtucker Registered

    Joined:
    Dec 1, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I manage a dedicated server with cPanel/WHM installed. A couple nights ago I noticed my email was no longer authenticating. I attempted to log in to cPanel and get

    Internal Server Error


    500


    Could not fetch uid or gid for : netstuc8
    cpsrvd/11.30.5.2 Server at mydomain.com


    Then about a night ago it started working again, and then again stopped authenticating this morning. I haven't made any server configuration changes in months. I confirmed the netstuc8 user still exists in /etc/passwd, and resetting the password in WHM has no effect. My other cPanel accounts function just fine on the same server. I am out of ideas as far as what to try at this point. Any help would be greatly appreciated, thank you.
     
  2. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    Put the cPanel build in stable mode (if it is not) and then try /scripts/upcp --force. I hope that should solve this error forever.
     
  3. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are you seeing anything in /usr/local/cpanel/logs/error_log location when you try to log into that account and have that error occur?

    Next, what url are you using? Can you try the IP address for your server instead? I'm wondering if the domain is going back and forth between different IP addresses and sometimes it is hitting the other IP address that isn't your server's IP.
     
  4. jedgtucker

    jedgtucker Registered

    Joined:
    Dec 1, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Cpanel is in stable mode and I ran /scripts/upcp --force but still have the same problem.

    I am accessing the Cpanel control panel via IP, when I attempt a login, the error log records the following:

    Internal Server Error: "GET /frontend/x3/index.html?post_login=53892526947626 HTTP/1.1" 500 Could not fetch uid or gid for : netstuc8
     
    #4 jedgtucker, Dec 1, 2011
    Last edited: Dec 1, 2011
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you sure that "netstuc8" is the correct username? That error message can sometimes be indicative of an incorrect username being entered. You can run the following command to check this:

    Code:
    # id netstuc8
    If it is a valid username, you may want to consider opening a support ticket so we may check further.

    Thank you.
     
  6. jedgtucker

    jedgtucker Registered

    Joined:
    Dec 1, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    100% sure, will do, thanks
     
Loading...

Share This Page