The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Internal 500 Error

Discussion in 'General Discussion' started by Chriz1977, Dec 2, 2009.

  1. Chriz1977

    Chriz1977 Well-Known Member

    Joined:
    Sep 18, 2006
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    16
    Hi

    After a build of apache all my sites are broken with Internal Server 500 errors. I found this in the apache log :

    [Wed Dec 02 15:10:08 2009] [error] [client 212.183.140.100] SoftException in Application.cpp:357: UID of script "/usr/local/apache/htdocs/phpinfo.php" is smaller than min_uid, referer: http://78.xxx.xxx.xxx:2086/themes/x/xtra/index.php
    [Wed Dec 02 15:10:08 2009] [error] [client 212.183.140.100] Premature end of script headers: phpinfo.php, referer: http://78.xxx.xxx.xxx:2086/themes/x/xtra/index.php

    This was when I tried to run phpinfo command from inside whm. Any ideas what might be causing this error?

    Cheers
    Chriz
     
  2. jrianto

    jrianto Active Member

    Joined:
    Jun 9, 2008
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Have you tried running a WHM/cPanel update from WHM, then run EasyApache update again, usually that does the fixing.
     
  3. kbuser

    kbuser Well-Known Member

    Joined:
    Aug 25, 2008
    Messages:
    66
    Likes Received:
    2
    Trophy Points:
    8
    It sounds like you set the minimum user ID to be above all existing user IDs.
     
  4. cPanelDon

    cPanelDon cPanel Quality Assurance Analyst
    Staff Member

    Joined:
    Nov 5, 2008
    Messages:
    2,557
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    Please check all of the available Apache logs for additional information while reproducing the symptoms:
    Code:
    # tail -fvn0 /usr/local/apache/logs/*log
    By stock-default cPanel/WHM and EasyApache does not install a PHP information "phpinfo();" page into the Apache directory "htdocs" document root path. Per the log detail provided this appears to stem from a third-party WHM plug-in, WHMXtra; regarding the affected third-party software, this issue should be escalated to the vendor via their official contact and support methods:
    http://www.whmxtra.com/contact-us/
    http://www.whmxtra.com/helpdesk/
     
    #4 cPanelDon, Dec 2, 2009
    Last edited: Dec 2, 2009
  5. rachelm

    rachelm Well-Known Member

    Joined:
    Jan 26, 2005
    Messages:
    94
    Likes Received:
    1
    Trophy Points:
    8
    Looks like Chriz has two seperate issues, neither of which actually have to do with WHMXtra (I should know, I wrote that part :P).

    For the phpinfo, although that is part of Xtra it looks like kbuser was right, you have an improper minimum user id set in tweak settings, that part of our script runs as the apache user (which is usually nobody) so you may need to adjust your setting for that.

    However the 500 error after recompiling apache has nothing to do with Xtra or phpinfo, more likely you need to run fix home or permissions or better yet fix everything. This can be done via ssh or via Xtra. It probably happened if you enabled suphp when you recompiled or some other option.

    If you have any other issues or questions related to Xtra itself please open a ticket in our helpdesk as the cpanel forums are the wrong place for that and most likely nobody here can help you (I only found this thread by accident lol).
     
  6. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I suspect you are experiencing the same issue I am with any scripts added to /usr/local/apache/htdocs such as a phpinfo.php script.
    For the scripts to be executable they have to be chowned to apache.apache but every Apache rebuild via EasyApache moves the existing htdocs to a backup location and then generates a new default directory and copies the original contents back to it but it does not preserve ownerships at all so all the custom .php scripts give 500 errors until I go in and chown them back to apache.apache which is really quite annoying.
     
  7. fruithosting

    fruithosting Registered

    Joined:
    Apr 28, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    SoftException in Application.cpp:357: UID of script

    Having similar issues, but for my lack of knowledge of the WHM panel I am trying to follow exactly what processes in WHM are. Could someone tell me step by step what to do.

     
  8. linux77

    linux77 Member

    Joined:
    Sep 6, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I was running into the same error as Chriz77. My issue was my ownership and permissions were all screwed up because I was working as root user. after chown -R /home/user , then chown user.nobody /public_html/ and chmod 755 /public_html my index.php file worked. Make sure you permissions and file ownerships are correct.

    Cheers,
     
  9. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I believe this has happened to me. After recently upgrading from 11.28.x to 11.30.x (Release) I noticed that in WHM Basic Setup the minimum user ID was blank and higlighted in red.

    So I set it to the default minimum of 500

    Now many accounts get "Internal Server Error 500 - Could not fetch uid or gid for : root" when just even trying to log into cPanels!

    Can someone please tell me how to resolve this? Is there a safe way for me to change user ID numbers without breaking the system?
     
  10. ModServ

    ModServ Well-Known Member

    Joined:
    Oct 17, 2006
    Messages:
    332
    Likes Received:
    5
    Trophy Points:
    18
    Location:
    Egypt
    cPanel Access Level:
    Root Administrator
    Try to exeucte this

    Code:
    /usr/local/cpanel/bin/rebuild_phpconf 5 none suphp 1
    This will change your PHP5 handler to SuPHP, Activating PHPSuExec and turn off PHP4

    And don't forget to change the min_uid in Tweak Settings to that minimum user ID you have, You can know it in "/etc/passwd"
     
  11. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    376
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hi ModServ,

    On all servers my PHP5 handler has already been set to suPHP and PHP4 turned off for over a year now.

    Also, in WHM > Tweak Settings there is no listing for "min_uid"

    Thank you for taking the time to reply, but I'm thinking maybe your reply was directed at the original poster, so I'm going to start a separate thread for my issue just in case I'm mincing things in this thread.
     
  12. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    "The minimum user ID value used when creating new accounts." is set in:
    Main >> Server Configuration >> Basic cPanel & WHM Setup
     
Loading...

Share This Page